Closed Bug 1723950 Opened 1 year ago Closed 1 year ago

Login page is not triggered on atlassian.com with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 92
Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox92 --- verified
firefox93 --- verified

People

(Reporter: oanaarbuzov, Assigned: twisniewski)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image StrictVSStandard.png

Environment:
Browser / Version: Firefox Nightly 92.0a1 (2021-08-03), Firefox Release 90.0.2
Operating System: Ubuntu 20.04.2

Prerequisites:
ETP - Strict enabled.

Steps to reproduce:

  1. Navigate to https://www.atlassian.com/
  2. Click "My account" button.
  3. Click "Log in" from the drop down men.
  4. Observe the behavior.

Expected Behavior:
Redirect to "Login" page is performed.

Actual Behavior:
Redirect to the "Login" page is not performed.

Notes:

  1. Screenshot attached.
  2. The issue is not reproducible with ETP - Standard.

This appears to be an issue with the SmartBlock Optimizely shim not returning what the site expects. Here is their code:

    var campaignStates = window["optimizely"].get("state").getCampaignStates();

    // for each campaign state in object, transform data to desired format and add to object
    Object.keys(campaignStates).forEach(

It seems as though we will probably need to return empty objects/arrays/etc from more of the methods in the shim. I'll investigate ASAP.

Regressed by: 1714431
Has Regression Range: --- → yes
Assignee: nobody → twisniewski
Status: NEW → ASSIGNED

I've confirmed that improving the shim with the patch above helps fix this issue (and others).

Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98386363bea5
Shim more of the stubbed-out Optimizely API in its SmartBlock shim to fix more site breakage; r=denschub,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Comment on attachment 9235443 [details]
Bug 1723950 - Shim more of the stubbed-out Optimizely API in its SmartBlock shim to fix more site breakage; r?denschub

Beta/Release Uplift Approval Request

  • User impact if declined: More breakage likely on sites in private browsing/strict ETP, like for Atlassian login.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: Open a private browsing tab or a tab in Strict ETP mode. Visit https://www.atlassian.com/, click "my account" and "log in", and note it isn't working.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only affects sites using Optimizely trackers, only in strict ETP mode or private browsing, and users may still disable ETP on tabs if/where there are unexpected side effects.
  • String changes made/needed:
Attachment #9235443 - Flags: approval-mozilla-beta?

Comment on attachment 9235443 [details]
Bug 1723950 - Shim more of the stubbed-out Optimizely API in its SmartBlock shim to fix more site breakage; r?denschub

Approved for 92.0b2.

Attachment #9235443 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Tried to reproduce this in order to verify the fix but I could not reproduce the initial issue (not sure if it's because is OS-dependent or some changes happened on the site's side).

Oana, when time allows, could you please verify this is fixed on your end? Thanks!

Flags: needinfo?(oana.arbuzov)

Its seems to be working now, redirect to "Login" page is performed.

Tested with:
Browser / Version: Firefox Nightly 93.0a1 (2021-08-11), Firefox Release 91, Firefox Beta 92.0b2
Operating System: Ubuntu 20.04.2

Flags: needinfo?(oana.arbuzov)

Based on comment 10, marking this as Verified Fixed.

Status: RESOLVED → VERIFIED

The issue doesn’t reproduce on 8/23 Nightly 93.0a1 build, nor in Beta 92.0.0-beta.6, with Lenovo Tab M10 (Android 10).

You need to log in before you can comment on or make changes to this bug.