Closed Bug 1724105 Opened 3 months ago Closed 2 months ago

Allow parameters to be localised

Categories

(SeaMonkey :: Chat, enhancement)

enhancement

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.91
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.10)

Attachments

(1 file, 1 obsolete file)

At the moment cmd.*.params is used both for parsing of parameters and also providing usage information for /help
This can cause confusion for localisers and also make help less friendly to cZ users.

Attached patch 1724105-irc-params-25310.patch (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: less friendly /help messages
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: lots

Whilst here I have removed the unused getDocumentation function.
Parameter information for parsing is now stored in the cmdary object.
Help information is now only collected for those commands that can be issued from the console (i.e. typed in) which means some unused strings can be removed from chatzilla.properties
Those commands that do have parameters now have a cmd..helpUsage entry in chatzilla.properties that can be localised - change from cmd..params to cmd.*.helpUsage is to prompt localisers to now translate the strings - will probably need to post to l10n forums about it.

Attachment #9234788 - Flags: review?(frgrahl)
Attachment #9234788 - Flags: approval-comm-release?
Attachment #9234788 - Flags: approval-comm-esr60?

Changes since last patch:
Added some localization notes

Attachment #9234788 - Attachment is obsolete: true
Attachment #9234788 - Flags: review?(frgrahl)
Attachment #9234788 - Flags: approval-comm-release?
Attachment #9234788 - Flags: approval-comm-esr60?
Attachment #9235247 - Flags: review?(frgrahl)
Attachment #9235247 - Flags: approval-comm-release?
Attachment #9235247 - Flags: approval-comm-esr60?

Comment on attachment 9235247 [details] [diff] [review]
1724105-irc-params-v1_1-25310.patch

LGTM

At least 2 languages have partially translated params. Should a hint be added to just change the older .params to .helpUsage (this is what I did with de) if translated or something to communicate when the patch lands?

Attachment #9235247 - Flags: review?(frgrahl)
Attachment #9235247 - Flags: review+
Attachment #9235247 - Flags: approval-comm-release?
Attachment #9235247 - Flags: approval-comm-release+
Attachment #9235247 - Flags: approval-comm-esr60?
Attachment #9235247 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/dcdca80bec85
Allow parameters to be localised. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.10
Target Milestone: --- → seamonkey 2.91
You need to log in before you can comment on or make changes to this bug.