quicksearch no longer works after mozilla 1.2a

RESOLVED DUPLICATE of bug 171441

Status

()

Core
HTML: Form Submission
--
critical
RESOLVED DUPLICATE of bug 171441
16 years ago
5 years ago

People

(Reporter: Marc Bejarano, Assigned: Alexandru Savulov)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
the quicksearch functionality available on the main b.m.o page and on http://bugzilla.mozilla.org/quicksearch.html stopped working for me with when i upgraded from mozilla 1.2a to the 10/3/02 nightly 1.2b build for win32.  judging from the recent comments to bug 70907, i'm not the only one this is happening to.

Comment 1

16 years ago
at the risk of sounding irritating:

i would like to add that it is *extremely* annoying. it blocks my regular
searches in bugzilla for dupes, hence indirectly wasting QA-engineers-time.

oh, if only the bugzilla-query form were somewhat easier to use...

this is the error in the js-console:

Error: QuickSearch is not defined

Severity: major → critical
OS: Windows XP → All
Hardware: PC → All
This WFM in a current CVS build, as well as a tgz from a couple of days ago.

In any event, ->browser
Err, really -> browser
Assignee: endico → alexsavulov
Component: Query/Bug List → Form Submission
Product: Bugzilla → Browser
QA Contact: matty → vladimire
Version: unspecified → other

Comment 4

16 years ago
This did not begin in 1.2a. It started affecting me weeks and weeks ago and I'm
still using 1.1. Oddly it only seems to affect some people and not others.

Comment 5

16 years ago
Since 1.2a I also see this behavior.
Got this Error: uncaught exception: [Exception... "Component returned failure
code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)
[nsIDOMWindowInternal.sidebar]"  nsresult: "0x80040154
(NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame ::
http://bugzilla.mozilla.org/quicksearch.js :: go_to :: line 49"  data: no]

Maybe it's because I have the sidebar closed?

Comment 6

16 years ago
Here's an interesting clue, and a workaround for now: QuickSearch is still
working in my Bugzilla Sidebar. 

It doesn't work for me either on the normal opening page. I'm using a company
local version of Bugzilla rather than bugzilla.mozilla.org, so it's also not
anything specific to the Mozilla Bugzilla installation. 

Seeing as how it seems to only affect some people, perhaps investigating
possibly links with the Bugzilla sidebar being installed would be wise as well.

Comment 7

16 years ago
wfm on build 2002-10-18-04-trunk.. If there are javascript errors that are
breaking the page perhaps this is not form submission.

Comment 8

16 years ago
Hmmm. Interesting. Now that I worked around bug 171441 by deleting confreg.dat
while Mozilla is not running, Quicksearch again works for me on the same build
as before. I suspect that the js error about the factory not being registered
might be due to bug 171441.

Therefore, perhaps this is strangely actually a duplicate of bug 171441.
(Assignee)

Updated

16 years ago
Whiteboard: dupeme

Comment 9

16 years ago
The steps in bug 171441 fix the problem for me too. Marking as dupe.

*** This bug has been marked as a duplicate of 171441 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.