Closed Bug 1725353 Opened 4 months ago Closed 3 months ago

Store download permissions for the websites with multiple automatic downloads

Categories

(Firefox :: Downloads Panel, task, P3)

Desktop
Unspecified
task

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: ava8katushka, Assigned: ava8katushka)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When the download request is created, we check if the download was initiated by the user.
loadInfo->GetHasValidUserGestureActivation()
If so, we always allow and proceed.
If it is not initiated by the user, we check if there is a permission granted to this website to make multiple automatic downloads. There might be 4 possibilities.

NULL: The permission is not set.
Allow the download to proceed.
Set permission for this website to PROMPT_ACTION (would be used on the 2nd download) .

ALLOW_ACTION: the permission was explicitly set by the user.
Allow this website to proceed.
Just a normal download workflow.

DENY_ACTION: the permission was explicitly set by the user.
Cancel the download immediately.
Do not prompt user that download was blocked

PROMPT_ACTION: this permission was set after NULL. Notice, that while the user didn’t clarify their will to allow or deny action, this permission stays. So not one, but a stream of downloads could have PROMPT_ACTION permission.
Create a call to Downloads Panel
Add a new request to “website”s request objects : [requestBlocked1, requestBloked2…].

Blocks: 1711049

Updating the status to New since this is a future implementation (task) and does not need confirmation. The same update will get to the rest of similar tasks submitted to clear them out from the Unconfirmed QA triage list.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → ava8katushka
Status: NEW → ASSIGNED
Severity: -- → S3
Priority: -- → P3
Attachment #9236190 - Attachment description: Bug 1725353 - Store download permissions for the websites with multiple automatic downloads. r?gijs → Bug 1725353 - Store download permissions for the websites with multiple automatic downloads. r?mtigleY
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/875298dcdf93
Store download permissions for the websites with multiple automatic downloads. r=mtigley
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Flags: needinfo?(ava8katushka)
You need to log in before you can comment on or make changes to this bug.