Closed Bug 172584 Opened 20 years ago Closed 20 years ago

overflow: auto or scroll affects box height

Categories

(Core :: Layout, defect)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 145212

People

(Reporter: tometzky, Assigned: attinasi)

Details

Attachments

(1 file)

When 'overflow' property in a box (for example 'div') is set to
'scroll' or 'auto' it affects this box height.

With overflow 'auto' vertical scrollbar should never be visible if neither          
box nor any of its parent boxes have no height property - it should
simply get it's automatic height based on it's contents.

With overflow 'scroll' it should be visible according to CSS2 standard,
but it should not ever change computed box height.
Roc fixed this a few days back.  Got a bug number to dup to?
> it should not ever change computed box height.

Not quite. With overflow:scroll, we have to make the box bigger than the content
to make room for the scrollbar(s).

This bug is indeed fixed. Try today's build.

*** This bug has been marked as a duplicate of 145212 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.