Closed Bug 1726114 Opened 4 months ago Closed 4 months ago

Use clang toolchain for macosx native builds

Categories

(Firefox Build System :: Toolchains, task)

task

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Regressed 1 open bug)

Details

Attachments

(2 files)

No description provided.

Local builds don't use it, and currently the only builds that happen on
macs on automation are not using the clang toolchain, so they're not
going through the first condition, and the remainder of the mozconfig
is essentially no-ops (plus, the only builds on macs on automation that
do use mozconfigs at all are rusttests, for which those settings wouldn't
matter anyways).

Meaning in practice, the mozconfig is not doing anything useful.

For plain builds, that puts them more in line with local builds.

The Bugbug bot thinks this bug should belong to the 'Firefox Build System::Toolchains' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: General → Toolchains
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/aefa63e887a9
Remove build/macosx/local-mozconfig.common. r=firefox-build-system-reviewers,mhentges
https://hg.mozilla.org/integration/autoland/rev/79b3c0ca75fe
Use clang toolchain for macosx native builds. r=firefox-build-system-reviewers,mhentges
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Regressions: 1726782
Duplicate of this bug: 1704136
You need to log in before you can comment on or make changes to this bug.