Mozilla Firebird should not try to use $MOZILLA_FIVE_HOME

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: neil, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
dist/bin/phoenix is trying to launch $MOZILLA_FIVE_HOME/phoenix-bin, which is
probably not there.
(Reporter)

Comment 1

16 years ago
Created attachment 101781 [details] [diff] [review]
patch to search PHOENIX_HOME, not MOZILLA_FIVE_HOME
(Reporter)

Updated

16 years ago
Keywords: patch

Comment 2

16 years ago
*** Bug 173416 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
note that the current startup script can find the appropriate directory just
fine without any *_HOME environment variable set.  In the past, it was necessary
to use the variable if the startup script was symlinked to.  There might be a
good reason to keep such functionality with Phoenix, but I can't think of one.

The run-mozilla.sh script sets the MOZILLA_FIVE_HOME variable to the appropriate
value, which is still needed by XPCOM.
(Reporter)

Comment 4

16 years ago
andrew, agreed.  the problem is that some systems have mozilla_five_home set, so
starting phoenix is impossible.

Comment 5

16 years ago
Comment on attachment 101781 [details] [diff] [review]
patch to search PHOENIX_HOME, not MOZILLA_FIVE_HOME

bryner, can you review this patch please? Thanks.
Attachment #101781 - Flags: review?(bryner)
(Assignee)

Comment 6

16 years ago
Comment on attachment 101781 [details] [diff] [review]
patch to search PHOENIX_HOME, not MOZILLA_FIVE_HOME

This is going to break things. run-mozilla.sh sets MOZILLA_FIVE_HOME in the
environment, and XPCOM explicitly looks for the value of that environment
variable.
Attachment #101781 - Flags: review?(bryner) → review-
(Reporter)

Comment 7

16 years ago
bryner, this doesn't change that at all.  this patch just ignores the user-set
value if there is one.  some package managers set the value of moz_five_home to
the (correct) location of mozilla.  this patch tells phoenix to ignore that,
which I think it should.  i.e., /usr/local/mozilla/phoenix-bin will NEVER exist
if you installed mozilla via portage or whatever.

also, XPCOM seems perfectly happy with this patch.

Comment 8

16 years ago
> run-mozilla.sh sets MOZILLA_FIVE_HOME in the environment

and with the patch, it still does.  the run-mozilla.sh script overrides anything
that was set in the environment.

and again, I don't know of any useful functionality that can be gained by
looking at any *_HOME from the environment.  My vote would be to remove it from
the mozilla startup script completely.
(Assignee)

Comment 9

16 years ago
Comment on attachment 101781 [details] [diff] [review]
patch to search PHOENIX_HOME, not MOZILLA_FIVE_HOME

Sorry, I should have read that closer.	r=me.
Attachment #101781 - Flags: review- → review+
(Reporter)

Comment 10

16 years ago
especially with phoenix potentially changing its name, I agree with Andrew that
these lines should probably just be removed.

Updated

16 years ago
Summary: phoenix should not try to use $MOZILLA_FIVE_HOME → Mozilla Firebird should not try to use $MOZILLA_FIVE_HOME
(Assignee)

Comment 11

16 years ago
I went ahead and just removed the environment variable check.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.