Closed Bug 1727189 Opened 3 months ago Closed 3 months ago

Update pdf.js to version 2.11.142

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: bdahl, Assigned: bdahl)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

#13879 Fix the global variable definitions in test/resources/reftest-analyzer.js (issue 13862)
#13867 [api-minor] Re-factor the internal renderingIntent, and change the default intent value in the PDFPageProxy.getAnnotations method
#13882 [api-minor] Remove the closure from the PDFWorker class, in the src/display/api.js file
#13883 Improve caching of Annotations-data, by using a Map, in the API
#13884 Update packages and translations
#13887 Bump path-parse from 1.0.5 to 1.0.7
#13890 Update some deprecated ESLint rules
#13886 Re-factor the BaseException.name handling, and clean-up some code
#13896 Simplify the ReadableStream polyfill
#13892 Move some validation, in Dict.merge, used during merging of sub-dictionaries (PR 13775 follow-up)
#13900 [api-minor] Stop translating logical assignment in non-legacy builds (PR 12887 follow-up)
#13911 Ensure that the TESTING define can always be overridden in gulpfile.js
#13913 Fix pdf_viewer definitions
#13905 Re-factor loadAndEnablePDFBug and PDFBug.init
#13904 Re-factor the LocalTilingPatternCache to cache by Ref rather than Name (PR 12458 follow-up, issue 13780)
#13899 [Regression] Re-factor the internal includeAnnotationStorage handling, since it's currently subtly wrong
#13920 Extend the glyph maps for standard respectively Calibri fonts (issue 13916)
#13921 Update packages and translations
#13922 Enable the ESLint object-shorthand rule in the extensions/chromium/-folder
#13908 [api-minor] XFA - Support text search in XFA documents.
#13660 XFA - Disable xfa rendering for XFAF pdfs

Assignee: nobody → bdahl
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

(In reply to Gary [:streetwolf52] from comment #3)

Created attachment 9237950 [details]
Log file from using shift-Ctrl-J

Hoping the log file I captured this way has some more useful information. The interesting entry has 6 tabs on it so I had to save the log six times which each tab open. Go to the line that says 'Too Many Requests'. This is a couple of lines below where the parent record starts. Do the same for the other files.

Gary, I assume this comment was meant for another bug?

Blocks: 1706133
Flags: needinfo?(garyshap)
You need to log in before you can comment on or make changes to this bug.