If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

loading the chess.net applet causes the browser to crash

RESOLVED DUPLICATE of bug 115917

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 115917
15 years ago
7 years ago

People

(Reporter: Heiko Kampmann, Assigned: Joe Chou)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910

When loading the chess board login applet from chess.net Mozilla crashes
(http://www.chess.net/play/java/index.shtml).
I've tried to load the applet a couple of times. Mostly Mozilla crashed while
loading. Sometimes the login mask appeared, but then the login causes a crash.


Reproducible: Always

Steps to Reproduce:
1. load www.chess.net/play/java/index.shtml


Actual Results:  
the browser crashed

Expected Results:  
it should not crash ;-)

Comment 1

15 years ago
wfm using build 20021004 on Win2k (trunk) + JRE 1.4.1.
Assignee: asa → joe.chou
Component: Browser-General → OJI
Keywords: crash, stackwanted
QA Contact: asa → pmac

Comment 2

15 years ago
WorksForMe using Mac/2002091908/9.2.2. Heiko, please provide a TalkBack report ID for this 
crash.
(Reporter)

Comment 3

15 years ago
Greg, the Talkback ID is TB12100838X. The crash occurs on Mac/2002091014/9.2.1

Updated

15 years ago
Whiteboard: TB12100838X

Comment 4

15 years ago
MRJ crash.

MRJPlugin + 0x12078 (0x3de15328)
MRJPlugin + 0x16bb8 (0x3de19e68)
MRJPlugin + 0x1278c (0x3de15a3c)
MRJPlugin + 0x14008 (0x3de172b8)
ProxyJNIEnv::FindClass() [ProxyJNI.cpp, line 284]
init_netscape_java_classes() [jsj.c, line 348]
jsj_ConnectToJavaVM() [jsj.c, line 482]
JSJ_AttachCurrentThreadToJava() [jsj.c, line 685]
map_js_context_to_jsj_thread_impl() [lcglue.cpp, line 209]
jsj_EnterJava() [jsj_utils.c, line 458]
JSJ_ConvertJavaObjectToJSValue() [jsj.c, line 842]
nsJVMManager::WrapJavaObject() [nsJVMManager.cpp, line 440]
nsHTMLAppletElementSH::GetPluginJSObject() [nsDOMClassInfo.cpp, line 5548]
nsHTMLExternalObjSH::PostCreate() [nsDOMClassInfo.cpp, line 5408]
XPCWrappedNative::GetNewOrUsed() [xpcwrappednative.cpp, line 401]
XPCWrappedNative::GetNewOrUsed() [xpcwrappednative.cpp, line 287]
XPCConvert::NativeInterface2JSObject() [xpcconvert.cpp, line 1058]
XPCConvert::NativeData2JS() [xpcconvert.cpp, line 460] 

Comment 5

15 years ago
Didn't find dupes, marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
Whiteboard: TB12100838X

Comment 6

15 years ago
Olivier, this looks like a dupe of 115917. 

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 115917 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.