Closed Bug 172824 Opened 17 years ago Closed 17 years ago

colgroup does not function

Categories

(Core :: Layout: Tables, defect, major)

defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 4510

People

(Reporter: Stevan_White, Assigned: karnaze)

References

()

Details

Table colgroups don't seem to work at all any more.
Setting col style has no effect, nor does align or lang.

I have checked it in Windows 98 (build id2002091014) and Mandrake Linux 9.0, and
also see the problem in Netscape 7 on both platforms.

This is at least since release 1.0 -- I know colgroups were working in Netscape 6.

I double-checked my HTML files with MSIE 6 -- colgroups work correctly there.
yep.

Please understand that while column background should be painted, 'color' will
have no effect. This is because in CSS, inheritance is exclusively through the
element tree and <col> elements do not actually contain <td>.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All

*** This bug has been marked as a duplicate of 4510 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Bug 4510 seems only to refer to CSS int the style attribute.
Colgroup also fails to work for html attributes.

For example, these attributes in a col element fails to align the
column to a decimal point:
  align="char" char="."
Also the lang attribute: on my system, the second column is rendered identically
to the third column, which is different from the first:
  <table>
  <colgroup> <col /> <col lang="RU" /> <col /> </colgroup>
  <tbody>
  <tr><td><span lang="RU">Росский</span></td><td>Росский</td><td>Росский</td></tr>
  </tbody>
  </table>
(This probably depends on font settings)

The width attribute works.  The align and valign attributes don't work, but
I suppose it could be argued the are really style properties.
The above Russian example will need 
  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-5" />
in the html head. (pardon)
See bug 915
Verfied dupe of bug 915
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.