Download Manager should purge deleted files

RESOLVED DUPLICATE of bug 132755

Status

SeaMonkey
Download & File Handling
--
enhancement
RESOLVED DUPLICATE of bug 132755
16 years ago
14 years ago

People

(Reporter: peter shinners, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020917
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020917

The download manager should automatically delete files from its list that have
been removed locally.

Since the download manager already knows where the file is located, it would be
simple to check if it still exists when the window is opened. This would really
make the download manager a useful tool, since i could track downloaded files
that i haven't dealt with yet.

Reproducible: Always

Steps to Reproduce:
What if i save it on the Network on the network is not availible ?
The network timeout is very slow and the whole download manager is blocked until
this timeout.

The DM muust check all files and i think this is very bad.
suggesting WONTFIX
(Reporter)

Comment 2

16 years ago
Hmm, a potential problem, i suppose it would need to be an option if
implemented. I personally never have more then 3 or 4 files in the manager at
any time anyways.

When the manager is opened it could start scanning the files in the background.
files that are deleted could be greyed out once they are discovered missing. the
next session for the manager they would be gone. but this is starting to get
pretty complex.

Perhaps a simple option to remove files past a certain number of days? like
remove  files from list after 1 week?
QA Contact: sairuh → petersen
>Perhaps a simple option to remove files past a certain number of days?

yes this is a "good" enhancement but already filed :-)
I hope you don't disagree if i dupe it...


*** This bug has been marked as a duplicate of 132755 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.