Rename Preferences to Options

VERIFIED FIXED

Status

()

Firefox
Menus
--
trivial
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: djst, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Since Phoenix is a redesign of the UI, maybe we could fix a strange decision in
Mozilla. That is to place the Preferences item in the Edit menu. 

In almost every program I know of in Windows, the Preferences (or Options, as
it's normally called) is placed at the bottom of the tools menu. List of
programs that I've seen that has Preferences/Settings/Options under Tools:

Windows Explorer / IE
Office (all versions I've seen)
Windows Media Player
SmartFTP
Texturizer (my own program, hehe)
Windows Movie Maker
Microsoft Visual Studio
Outlook Express
Grokster
RealOne Player

Hmm.. that's about all programs I have installed. Anyway, it seems to be the
standard, at least on the Windows platform. I don't remember where Konqueror
places it's settings.

Comment 1

15 years ago
I notice this has been done as of the October 7 build. Thank you.

Before this bug is closed, would it be too much to ask you to rename it to
"Options" as in most other Windows apps? The dialog box title bar would also
have to be changed from "Preferences" to "Options".
(Reporter)

Comment 2

15 years ago
Interesting how this bug is fixed and still unconfirmed! :)
Changing summary as per comment 1 and leaving it open until developers decide.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Move Preferences to the Tools menu → Rename Preferences to Options

Comment 3

15 years ago
Not in the plans. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
*** Bug 174480 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Why not in the plans?  Tools > Options is present in many applications.  I can't
think of one that has Tools > Preferences.
(Reporter)

Comment 6

15 years ago
Dean, I want this changed as much as you do, but I also have to be honest and
say that there are a few non-MS programs that actually calls it Preferences
instead of Options:

* RealOne Player

Hmm that's the only one I could think of.

Comment 7

15 years ago
Opera 6 and Photoshop 5 use "Preferences". It's placed under the "File" Menu,
which makes the most sense, in my opinion. Flash MX also uses "Preferences".
(Reporter)

Comment 8

15 years ago
Reopening bug since Ben Goodger has fixed this.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 9

15 years ago
Reassigning.
Assignee: blaker → ben
Status: REOPENED → NEW
(Reporter)

Comment 10

15 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Almost, but the accesskey needs to be 'O' instead of 'o'.

Comment 12

15 years ago
Changed it to 'O'.

Comment 13

14 years ago
Although this is fixed, I should point out that Phoenix is both a Windows and a
Linux app, and Linux apps frequently have Preferences menus rather than Options
menus.

Not being familiar with the build process, would it be possible to have the
Windows builds use Options and the Linux builds use Preferences?
(Reporter)

Comment 14

14 years ago
Was that a joke? Why put extra effort in making it different in Linux?

Comment 15

14 years ago
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/locale&command=DIFF_FRAMESET&file=browser.dtd&rev1=1.48&rev2=1.49&root=/cvsroot
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/locale&command=DIFF_FRAMESET&file=browser.dtd&rev1=1.49&rev2=1.50&root=/cvsroot
v.
Status: RESOLVED → VERIFIED

Comment 16

14 years ago
Please reverse this code. You list almost only Micosoft products as examples of
"Tools | Options" as if that were a good reason. Let's not copy Microsoft here.
Are the program settings or preferences really a "tool"? I don't think so.
Counter-reasons are the better-than-MS programs (that I use):

Adobe Acrobat            - Edit | Preferences
Corel WordPerfect Office - Tools | Settings
Lotus Notes              - File | Preferences
Lotus Organizer          - File | User Setup
Total Commander          - Configuration | Options
IrfanView                - Options | Properties
MicroStation (CAD)       - Workspace |Preferences

Comment 17

14 years ago
And you only list applications that are less-frequently used that MS apps, or
have extremely confusing menus (IrfanView).
(Reporter)

Comment 18

14 years ago
This bug is verified and approved by drivers of mozilla.org. Rant about the
decision will not change anything. Please take your discussion to the
MozillaZine threads. Thank you.

Comment 19

14 years ago
david: um, excuse me, but i don't see a single stamp from anything resembling
a driver in this bug. you're welcome to tell people to rant elsewhere, but
please don't misrepresent a bug or drivers.

[to everyone else: this is not saying that drivers or staff don't approve of
the mozilla/browser module owner(s)' decissions. further: drivers currently
manage seamonkey, as such the people who count wrt whether a change to
mozilla/browser is ok are staff (not drivers) and their delegate(s) the module
owner(s) both of whom seem to be undisturbed by the current course.]
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.