Closed Bug 1729367 Opened 1 year ago Closed 1 year ago

CamerasParent causing failures in getUserMedia related tests on Windows 10 x86 WebRender

Categories

(Core :: WebRTC, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox96 --- fixed

People

(Reporter: ng, Assigned: ng)

References

Details

Attachments

(8 files)

[task 2021-09-03T22:19:40.306Z] 22:19:40 INFO - PID 3960 | WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"CamerasParent 1","state":"(none)","filename":"/builds/worker/checkouts/gecko/dom/media/systemservices/CamerasParent.cpp","lineNumber":1105,"stack":["resource://gre/modules/nsAsyncShutdown.jsm:addBlocker:162"]}] Barrier: profile-before-change

https://treeherder.mozilla.org/jobs?repo=try&author=mfroman%40mozilla.com&selectedTaskRun=RJhd1-SZRuavtxG1Fhxfbw.0

https://treeherder.mozilla.org/logviewer?job_id=350494858&repo=try&lineNumber=7439

These look potentially related as well:
https://treeherder.mozilla.org/jobs?repo=try&author=mfroman%40mozilla.com&selectedTaskRun=d4egtGeNT5iM1w7MhorhSQ.0
https://treeherder.mozilla.org/logviewer?job_id=350495332&repo=try&lineNumber=8733

Could the sharing failures here be caused by CamerasParent locking up in an earlier test?
https://treeherder.mozilla.org/jobs?repo=try&author=mfroman%40mozilla.com&selectedTaskRun=WOtg5xvIQ1SE_w_S5raEdg.0

Summary: CamerasParent causing failures in getUserMedia related tests on Windows 10 x86 WebRender opt → CamerasParent causing failures in getUserMedia related tests on Windows 10 x86 WebRender

(In reply to Nico Grunbaum [:ng, @chew:mozilla.org] from comment #0)

Could the sharing failures here be caused by CamerasParent locking up in an earlier test?
https://treeherder.mozilla.org/jobs?repo=try&author=mfroman%40mozilla.com&selectedTaskRun=WOtg5xvIQ1SE_w_S5raEdg.0

Yes, and in particular an earlier screen sharing test. I suspect it's related to bug 1729362, even though there are some runs in debug where we hit this rather than the assert in bug 1729362. Could be a fluke.

See Also: → 1729362
Assignee: nobody → na-g
Status: NEW → ASSIGNED

This will allow the following cherry-pick to apply more easily, and it nets us a fix for the inability to capture OpenOffice on Win

Cherry-pick of 439ffe462a66ad9fa9a251b265e4ab28c2647d25
See review https://webrtc-review.googlesource.com/c/src/+/171723

Depends on D129711

This is the first of two upstream patches which address a window enumeration deadlock when querying window titles of the windows owned by the querying process.
Neither truely fixes the issue.

Cherry-pick of 449a78b1e20ea85b11f967cf3a184ee610ce21c3
See review: https://webrtc-review.googlesource.com/c/src/+/195365

Depends on D129712

This restores the code from P0, which was removed to make cherry-picking 439ffe462a66ad9fa9a251b265e4ab28c2647d25 and 449a78b1e20ea85b11f967cf3a184ee610ce21c3 easier.

Depends on D129713

This is a altered version (to account for file name changes) of
upstream's 78c73477c75f3262cad837ce7b46adf284166b14.

Attachment #9248092 - Attachment description: Bug 1729367 - P4 - Restore PID recording post cherry-pick;r?mjf → Bug 1729367 - P6 - Restore PID recording post cherry-pick;r?mjf
Attachment #9248109 - Attachment description: WIP: Bug 1729367 - PX1 - restore mac PID tracking using new API;mjf → WIP: Bug 1729367 - P7 - restore mac PID tracking using new API;mjf
Attachment #9248109 - Attachment description: WIP: Bug 1729367 - P7 - restore mac PID tracking using new API;mjf → Bug 1729367 - P7 - restore mac PID tracking using new API;r?mjf
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/f294d3c331ad
P0 - Temp revert of Windows pid capture to allow for clean cherry-pick;r=mjf
https://hg.mozilla.org/mozilla-central/rev/f08497b4423e
P1 - ws fixups to match upstream to cleanly cherrypick;r=mjf
https://hg.mozilla.org/mozilla-central/rev/f909dc428e52
P2 - Cherrypick OpenOffice capture fix for underlayment;r=mjf
https://hg.mozilla.org/mozilla-central/rev/30b766eaa3a4
P3 - Cherry-pick win window enumeration deadlock fix PT1;r=mjf
https://hg.mozilla.org/mozilla-central/rev/9af9cf9696cb
P4 - Cherry-pick win window enumeration deadlock fix PT2. r=ng
https://hg.mozilla.org/mozilla-central/rev/d0bb0a3af9cc
P5 - Change line endings back to LF. r=ng
https://hg.mozilla.org/mozilla-central/rev/72a83cb2e571
P6 - Restore PID recording post cherry-pick;r=mjf
https://hg.mozilla.org/mozilla-central/rev/1495ca5ef535
P7 - restore mac PID tracking using new API;r=mjf a=webrtc-update
Regressions: 1740903
No longer regressions: 1759734
No longer regressions: 1760843
You need to log in before you can comment on or make changes to this bug.