Closed Bug 1730121 Opened 1 year ago Closed 1 year ago

"Parser Error. Could not find 'VCALENDAR' component." when synchronising with SOGo CalDAV

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: frederick888, Unassigned)

References

Details

Attachments

(4 files)

Attached image Event parsing error

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

Subscribe to https://sogo.tsundere.moe/SOGo/dav/public/frederick888@tsundere.moe/Calendar/60-6139EC80-3-50B31E80/ in Calendar. This is a public calendar for testing purpose, no authentication required.

Actual results:

No events/tasks show up in Calendar.

In Error Console, can see:
console.error: Lightning:
Parser Error. Could not find 'VCALENDAR' component.

Expected results:

Events and tasks are imported normally.

Attached image Task parsing error

By the way the issue was originally reported at https://github.com/jobisoft/DAV-4-TbSync/issues/269.

All the logs and screenshots were produced using the native CalDAV function though.

Blocks: tb91found
Component: Untriaged → Address Book

The calendar seems to require credentials, so can't test.
Is this still an issue?

@Magnus Did you tick 'This location doesn't require credentials'? I just tested it out again and I was able to see the 'Create New Calendar' dialogue without providing credentials.

By the way, the old test event & task were on 30 Sep so even if you had subscribed to the calendar successfully, you wouldn't have seen any events/tasks without winding back (there were still warnings in Error Console though). For your convenience, I just created two new events on 1 Nov and 1 Dec respectively.

I get that far. It's just that after its subscribed, then I get the auth prompt.

@Magnus Did you try to create events? Viewing doesn't need authentication but creating / modifying do.

No, simply connected. (Tested on trunk though, maybe something is different...)

@Magnus Oh wait... I think it didn't ask me credentials since it automatically picked up one from the saved passwords. I just created a new profile and tried the link, and it asked me for credentials as well.

Not sure why it's designed in such a way (if it can pick up credentials from saved ones, why doesn't it do so when 'This location doesn't require credentials' is not enabled to make it consistent? If 'This location doesn't require credentials' is indeed enabled, why even prompt for credentials anyway?), but after clicking on 'Cancel' in the password prompt pop-up, still I can see the warnings in Error Console complaining that the events cannot be parsed.

Component: Address Book → Provider: CalDAV
Product: Thunderbird → Calendar

Yes, that fixed it! Thank you both for looking into this and kudos Landry!

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.