Closed Bug 1730218 Opened 3 years ago Closed 3 years ago

SuggestURLTemplate isn't working in SearchEngines policy

Categories

(Firefox :: Enterprise Policies, defect, P2)

defect

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- fixed
firefox94 --- wontfix
firefox95 --- wontfix
firefox96 --- fixed

People

(Reporter: mkaply, Assigned: mkaply)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

SuggestURLTemplate isn't working on policies

It's a typo:

suggestUrlGetParams: newEngine.SuggestURLTemplate,

should be

suggest_url

So when we fix this, unfortunately engines that were already added won't get "fixed".

Wondering if there is some clever way to do that?

Any ideas Mark?

Flags: needinfo?(standard8)

I guess the question is can I easily update the suggest_url in an existing engine.

We don't have an easy way to do this currently.

I think you'd need to have a new function for updatePolicyEngine that call through to engine._updateFromManifest.

That would probably do enough. Though... if we did something like bug 1445134, then we wouldn't have to worry about this since we'd presumably always read/construct from the latest details.

On a possibly separate note, at some stage we should probably think about having strict identifiers for these - not just necessarily the names.

Flags: needinfo?(standard8)
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/6c28034df317
Fix suggest_url in policies. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Comment on attachment 9251024 [details]
Bug 1730218 - Fix suggest_url in policies. r?Standard8

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Policy only, parity with 96
  • User impact if declined: Suggest URLs don't work in policy
  • Fix Landed on Version: 96
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Automated test, policy only.

Requires bug 1481946 first

Attachment #9251024 - Flags: approval-mozilla-esr91?

Comment on attachment 9251024 [details]
Bug 1730218 - Fix suggest_url in policies. r?Standard8

Approved for 91.5esr.

Attachment #9251024 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: