Closed Bug 1730352 Opened 5 months ago Closed 4 months ago

Local storage fails for "file:" protocol

Categories

(Core :: Storage: localStorage & sessionStorage, defect)

Firefox 92
defect

Tracking

()

RESOLVED DUPLICATE of bug 1730419

People

(Reporter: dr.kral, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

With this version LOCAL STORAGE is associated with one page when the protocol is file rather with all pages. When page uses local storage (on server) the stoarge is associated with the protocol+domain. When on one's own computer just with the page.
Was OK until now. Work correctly with others -- Edge/Chrome/Opera

Actual results:

only the page saving the data can see it

Expected results:

all pages should see the stored data

The Bugbug bot thinks this bug should belong to the 'DevTools::Storage Inspector' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Storage Inspector
Product: Firefox → DevTools

I'm not sure what component in Firefox or JavaScript but the Bot is wrong about it being a dev tool

Component: Storage Inspector → General
Product: DevTools → Firefox
Component: General → Storage: localStorage & sessionStorage
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1730419
You need to log in before you can comment on or make changes to this bug.