Closed Bug 1731091 Opened 11 months ago Closed 11 months ago

Phantom event at the end of each day

Categories

(Calendar :: General, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ verified, thunderbird93+ verified)

VERIFIED FIXED
94 Branch
Tracking Status
thunderbird_esr91 + verified
thunderbird93 + verified

People

(Reporter: ilia-kats, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Actual results:

The calendar displays an event at the very end of each day (see attached screenshot). I did not enter these events, they cannot be edited (double-clicking them does nothing), and the tooltip when hovering is that of any other event that I hovered over previously. To be precise, right after starting Thunderbird, there is no tooltip. If I hover over any other event, say X, and then over the phantom event, then the tooltip of the phantom event will be identical to that of event X. If I next hover over event Y and then over the phantom event, the tooltip will be identical to that of event Y.

The phantom events show up in both daily view and weekly view. I'm not certain, but I think this did not occur in TB 78, only since TB 91.

Well that's a weird one! Are they associated with any particular calendar (ie. do they go away if you hide that calendar)? If so can you export the calendar and check for anything unusual?

It does not appear so. I've hidden all my calendars, the phantoms are still there.

Geoff, the "phantom" event is defined here https://searchfox.org/comm-central/rev/d3417c4dd066060bf1bdd0ed5424d14514121da2/calendar/base/content/calendar-event-column.js#47 and shown because of this rule https://searchfox.org/comm-central/rev/35c9e2929a5ae37d07192315db3787dc01f73441/calendar/base/themes/common/calendar-views.css#506

Does the <calendar-event-box> need to be defined there as a prototype? If yes, a calendar-event-box:not([hidden="true]) should do the trick to hide the phantom events.

Flags: needinfo?(geoff)

Ohhh, right, that thing. I'd forgotten about it. Henry's patch must've made it appear by setting the display.

Assignee: nobody → geoff
Blocks: tb91found
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(geoff)
Regressed by: 1694820
Target Milestone: --- → 94 Branch

Thanks for pointing out what I missed, Richard.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f00c9ad6c03b
Hide the dummy event box in <calendar-event-column>s. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9241744 [details]
Bug 1731091 - Hide the dummy event box in <calendar-event-column>s. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #): bug 1694820
User impact if declined: an extra box appears at the bottom of each column in the day/week calendar
Testing completed (on c-c, etc.): landed 6 days ago
Risk to taking this patch (and alternatives if risky): low

Attachment #9241744 - Flags: approval-comm-beta?

Comment on attachment 9241744 [details]
Bug 1731091 - Hide the dummy event box in <calendar-event-column>s. r=Paenglab

[Triage Comment]
Approved for beta

Attachment #9241744 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9241744 [details]
Bug 1731091 - Hide the dummy event box in <calendar-event-column>s. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #): bug 1694820
User impact if declined: an extra box appears at the bottom of each column in the day/week calendar
Testing completed (on c-c, etc.): only in 93.0b5 but I'm okay with that
Risk to taking this patch (and alternatives if risky): low

Attachment #9241744 - Flags: approval-comm-esr91?

Comment on attachment 9241744 [details]
Bug 1731091 - Hide the dummy event box in <calendar-event-column>s. r=Paenglab

[Triage Comment]
Approved for esr91

Attachment #9241744 - Flags: approval-comm-esr91? → approval-comm-esr91+

Verified testing the 91.2 release candidate on Windows 10.

You need to log in before you can comment on or make changes to this bug.