Closed Bug 173154 Opened 19 years ago Closed 19 years ago

Remove nsCOMPtr sizeof() hack

Categories

(Core :: XPCOM, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 107291

People

(Reporter: john, Assigned: john)

Details

According to the comments and all available good information, we have dropped
the compilers that choked on using forward declarations in a template.  Removing
the sizeof() hack, therefore, will make it so we forward-declare many classes we
currently have to #include, thus (likely) speeding up compilation.
Status: NEW → ASSIGNED
dupe.

*** This bug has been marked as a duplicate of 107291 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.