Closed Bug 1731663 Opened 4 months ago Closed 4 months ago

Firefox 93 and newer editions will work slower with old hardware - no more OpenGL compositing

Categories

(Core :: Graphics: WebRender, defect)

Firefox 93
defect

Tracking

()

RESOLVED DUPLICATE of bug 1731664

People

(Reporter: kaykaykay123, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Using Firefox 93.
With Firefox 93 Mozilla is throwing away OpenGL compositing (rendering), only Webrender stays.

Actual results:

User will need compatible GPU for Webrender, otherwise FF will use software Webrender.
Even with fully compatible GPU on systems with slow CPU Webrender works slower than OpenGL compositing (~ 20% slower).
Here for slow CPU I mean this: using FF loads CPU to 100% continuously.
I cannot find exact data about Webrender system requirements. It worked on AMD Terascale 2 with OpenGL 3.3 support. Maybe it'll work with all AMD/ATI Terascale chips (Radeon HD 2000 series and newer), but not previous ones.

Expected results:

Working OpenGL compositing option, as usual.
Please provide info about Webrender system requirements.

The Bugbug bot thinks this bug should belong to the 'Core::Graphics: WebRender' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
Duplicate of this bug: 1731664
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1731664
You need to log in before you can comment on or make changes to this bug.