Closed Bug 1731737 Opened 8 months ago Closed 8 months ago

[Linux] Call D&D event handler faster

Categories

(Core :: Widget: Gtk, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
94 Branch
Tracking Status
firefox94 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We sometimes miss reply to D&D motion event due to delayed D&D handler call. We can't call D&D handler directly from drag-motion event as it causes nested recursions and re-entrance in glib loop so use higher priority for the handler at least.

We sometimes miss reply to D&D motion event due to delayed DnsDragService::RunScheduledTask() call.
We can't call D&D handler directly from drag-motion event as it causes nested recursions and re-entrance
in glib loop so use higher priority for the delayed handler call at least.

Disable re-entrance of nsDragService::RunScheduledTask() which may happen when
we get D&D data from drag_drop event.

Provide more loggig to D&D code.

Blocks: linuxdad
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/07020830bb7c
[Linux] Call nsDragService::RunScheduledTask() event handler faster and disable its re-entrance r=emilio
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Regressions: 1733283
Regressions: 1735348
Regressions: 1735773
You need to log in before you can comment on or make changes to this bug.