Closed Bug 1732026 Opened 1 year ago Closed 1 year ago

[wpt-sync] Sync PR 30825 - Add reference links to imageBitmapRendering tests and fix flipped orientation test expectation.

Categories

(Core :: DOM: Core & HTML, task, P4)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 30825 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/30825
Details from upstream follow.

Andrew Wolfers <aswolfers@chromium.org> wrote:

Add reference links to imageBitmapRendering tests and fix flipped orientation test expectation.

Previous CL https://crrev.com/c/3139358 added tests to verify the effect
of the imageOrientation attribute in
ImageBitmapRenderingContext.transferFromImageBitmap. This CL adds links
to those tests' expectations so that they can be run as intended.

This CL additionally fixes one of the above tests which failed because
the test reference was not oriented correctly.

Bug: 1244465
Change-Id: I4508280fb5bc0c60f160c5764f3b61a3f021d135
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3164821
Reviewed-by: Juanmi Huertas \<juanmihd@chromium.org>
Commit-Queue: Andrew Wolfers \<aswolfers@chromium.org>
Cr-Commit-Position: refs/heads/main@{#922921}

Component: web-platform-tests → DOM: Core & HTML
Product: Testing → Core

CI Results

Ran 7 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 2 tests

Status Summary

Firefox

PASS: 2

Chrome

PASS: 2

Safari

PASS: 2

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8464ece2ee38
[wpt PR 30825] - Add reference links to imageBitmapRendering tests and fix flipped orientation test expectation., a=testonly
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d1455591250
[wpt PR 30825] - Add reference links to imageBitmapRendering tests and fix flipped orientation test expectation., a=testonly
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.