Closed Bug 1732375 Opened 4 months ago Closed 3 months ago

Close tab menuitem in menubar "File" menu (#menu_close) always says "Close Tab" in the singular, even when multiple tabs are selected

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 94
Desktop
Unspecified
defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: aminomancer, Assigned: cmkm, Mentored)

Details

(Whiteboard: [lang=js][lang=html])

Attachments

(1 file)

When you select multiple tabs and right-click one of them, the menuitem #context_closeTab has its l10n-id changed for plural form. But when you hit Alt+F under the same conditions, the equivalent menuitem in the File menu #menu_close remains in singular form, even though activating it does close all selected tabs, not just the active tab.

I suspect this is just missing because it's hard to notice this menuitem in the first place. It only appears when you open the menu with the keyboard, not when you click it. Or maybe changing the label dynamically would cause issues on macOS.

I know the dynamic labels in the tab context menu are kind of causing issues on Windows 10. It's a minor thing but when you select multiple tabs, and then right-click one of the selected tabs, then right-click one of the non-selected tabs, back and forth, you can see that the label is visibly changing after the popup has opened. The change happens on popupshowing but I guess there's just some lag between the javascript and fluent.

So if that can't be fixed then maybe this bug should be ignored. But ideally that could be fixed first and then the equivalent menuitem in the File menu given some logic for switching to a plural form.

Thanks 🙏

Changing severity to S4 because while the label is slightly misleading, it doesn't actually prevent the user from performing the close multiple tabs action.

I'm not sure this would make a good first bug, but might make a good "next" bug for someone who's already somewhat used to Firefox Desktop development.

Mentor: mconley
Severity: -- → S4
Priority: -- → P3
Whiteboard: [lang=js][lang=html]

Didn't I mention that in my OP? I actually just left the severity field default, I wasn't trying to suggest this was some kind of life-wrecking bug haha.

I still can't get mach bootstrap to work but I'm willing to write the JS if someone can assure me they will submit it for me. Unfortunately I noticed this dynamic label complicates things further. I'm not sure what the purpose is for setting a special label when gBrowser isn't inited, but I don't wanna break something I don't understand.

Hi aminomancer,

From what I understand, when you select several tabs and right click, the options have the word "Tabs" (in plural), however when instead of right-clicking, you press Alt + F, the options have the word Tab (in singular).

I can reproduce this in Firefox Nighlty 94.0a1, so I´ll mark this as New for visibility.

I'll add this to the Firefox Tabbed Browser component, if this is not the right one please route it to the correct one.

Thanks

Status: UNCONFIRMED → NEW
Component: Menus → Tabbed Browser
Ever confirmed: true

The component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
Assignee: nobody → jhirsch
Status: NEW → ASSIGNED
Attachment #9245319 - Attachment description: WIP: Bug 1732375 - Update file menu close tab item to reflect multiple tabs selected → Bug 1732375 - Update file menu close tab item to reflect multiple tabs selected r?jhirsch
Pushed by jhirsch@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9e4cfd85375
Update file menu close tab item to reflect multiple tabs selected r=jhirsch,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.