mail time is always shown in GMT

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
11 years ago

People

(Reporter: di.ma, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The time of my mails (incoming time, sent time etc.) is shown only in GMT time
in the mail client! Although my XP is set to GMT+1 (Berlin time, CET). Mozilla
is just showing GMT +0000 and also transmit mail with GMT +0000!

Is it possible to set Mozilla to use local time for mail transmissions?

Is this a Mozilla problem or a problem of my "prefs.js" settings? If it's an
settings problem how do fix it?

My Mozilla version: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.1b)
Gecko/20020722
(Reporter)

Comment 1

16 years ago
The same behavior happens on my Win2k computer with the same timezone settings!
So it seems to be replicable!

Comment 2

16 years ago
Maybe I can shed some light on this as I have a /similar/ problem that may
actually be caused by the same thing.

I live in England so my normal TZ is GMT, but is currently GMT+1 (DST). Mail and
NG posts I send from Moz are timestamped with the current clock time but with
+0000 instead of +0100. This isn't actually a bug in Mozilla, but in Windows. My
machine dual boots (with FreeBSD) and both OSen are set to *not* automatically
adjust for DST (to stop the clock being adjusted twice). Under FreeBSD Moz
timestamps messages correctly (clock time +0100) but in Windows, Outlook Express
does the same as Moz (+0000).

The bug in Windows is deliberate ("by design" in MS-speak) to allow Windows to
handle timestamps on FAT filesystems (which don't store TZ/DST info) correctly
when comparing with files on NTFS (needless to say this only affects NT-class
Windows).

http://www.codeproject.com/datetime/dstbugs.asp gives a very detailed
explanation of the cause and effect of this "feature". It also references 2 MSKB
articles (one of which is no longer available). Also these 2 KB articles cover it:

http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q129574
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q190315

In all cases they refer to timestamping on /files/ but since the "broken" code
is in the C runtime libs and not the filesystem drivers it appears that is
affecting everything that uses the C library time functions (this is supported
by the fact that in the cygwin shell ``date +%z'' returns +0000, not +0100

Since this is not actually a Moz bug I guess this will be marked INVALID or
WONTFIX but it would be neat if we could address it since OE gets it wrong as
well :-)

If "Automatically adjust for DST changes" is *un*checked on the timezone tab in
Adjust Date/Time then the value DisableAutoDaylightTimeSet is set to 1 in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

but if "Automaticallly adjust..." is checked then DisableAutoDaylightTimeSet is
removed (rather than being set to 0; if you set it to 0 in the registry then
Windows will remove the value). It would seem to be easy to handle this by
checking if DisableAutoDaylightTimeSet is set *and* DST is in effect then add 1
to the UTC offset returned by Windows (or subtracting 1 hour from the time).

Comment 3

16 years ago
Reporter (di.ma) -- are you satisfied with Parish's explanation in comment 2?
If so, please mark this bug as Resolved/Invalid.
(Reporter)

Comment 4

16 years ago
I will live with this behavior - although it would be great to have improvements
against Outlook ;-)!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.