Closed Bug 1732426 Opened 1 year ago Closed 1 year ago

The sidebar search bar doesn't respect theme color on Windows

Categories

(Firefox :: Theme, defect, P3)

Desktop
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1488779
Tracking Status
firefox94 --- affected

People

(Reporter: cbaica, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-theme])

Attachments

(1 file)

Affected versions

  • Fx94.0a1

Affected platforms

  • Windows 10

Pre-conditions

  • browser.theme.temporary.monochromatic.enabled = true
  • Select a bold the Monochromatic theme e.g. Elemental - bold

Steps to reproduce

  1. Launch Firefox
  2. Open the sidebar by pressing CTRL+H.
  3. Observe the search bar inside the sidebar.

Expected result

  • Search bar has the same theme color as the regular search bar or address bar.

Actual result

  • The search bar is white.

Regression range

  • Not a regression.

Additional notes

  • Issue occurs for all bold themes.
  • Issue also occurs for Cheers - balanced (that theme also has the bar color a shade of dark).
  • The same design is also for the default dark theme in older Fx versions.
  • Search bar and address bar are correctly themed. The expectation is that this would be themed as well.
Has STR: --- → yes

Changing severity to S3 because there's only one theme affected by this issue.

Severity: normal → S3
Whiteboard: [fidefe-theme]

We don't currently have a way for the theme to set its color. This box is white on Windows because we use system colors to theme this search box, and as of now Windows always uses light system colors. We'd need to make this box theme-aware, which I think would be difficult given that it's a XUL component using -moz-default-appearance: searchfield and it has its own shadow DOM.

Since this affects all themes, not just monochromatic themes, this is a dupe of bug 1488779.

Status: NEW → RESOLVED
Closed: 1 year ago
Priority: -- → P3
Resolution: --- → DUPLICATE
Summary: [Monochromatic Themes] The sidebar search bar doesn't respect theme color → The sidebar search bar doesn't respect theme color on Windows
You need to log in before you can comment on or make changes to this bug.