Closed Bug 1732746 Opened 8 months ago Closed 7 months ago

tabs not dragging

Categories

(Core :: Widget: Gtk, defect, P1)

Firefox 94
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1735348

People

(Reporter: zlice555, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0

Steps to reproduce:

possible continuation of https://bugzilla.mozilla.org/show_bug.cgi?id=1732116 ?

drag tabs stopped working today

sometimes they will, then they all stop in every window

The Bugbug bot thinks this bug should belong to the 'Firefox::Tabbed Browser' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Tabbed Browser
OS: Unspecified → Linux

Hi zlice,
I have tried to reproduce the issue on Windows 10 and Ubuntu 20, on Firefox Nightly 94.0a1 (2021-09-28)(64-bit) and Release 92.0.1 (64-bit) versions, but I was unable to reproduce it. Tabs behavior is correct when dragging.
Could you answer the following questions in order to further investigate this issue?

  1. Does this issue happen with a new profile? Here is a link on how to create a new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

Can you test the issue while in Safe Mode (Safe Mode disables add-ons, extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems). You can find helpful info here : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode.

  1. Does this issue occur in the latest nightly version of firefox? Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/

  2. Are you using any addons? If so, please list them. Please, can you go to Help -> More Troubleshooting Information and copy at least the "Add-ons" information into an attachment here?

If you are still able to reproduce it, please, share further information with us, like screenshots, screen recording, or more specific steps.

I've assigned a component in order to get the dev team involved.
'Core - Widget GTK ' team: if the component is not relevant please change it to a more appropriate one.

Regards,
Jerónimo.

Component: Tabbed Browser → Widget: Gtk
Flags: needinfo?(zlice555)
Product: Firefox → Core

Please attach your about:support page.
Please run Firefox with:

MOZ_LOG="WidgetDrag:5"

env variable, reproduce the bug and attach the log here.
Thanks.

Blocks: linuxdad
Priority: -- → P1

Will run with MOZ_LOG="WidgetDrag:5" today.
Don't think I noticed this behavior yesterday. May have been fixed quick.

Attached file ff_drag_fail.txt

Took a while before I noticed tabs not dragging.

Don't have all the output, but that last bit is right when I noticed something not moving.

Flags: needinfo?(zlice555)

Any other type of dragging is working for you? I have noticed just now that I cannot drag anything in browser. I've had tab dragging issue few days ago too.

I'm on Manjaro KDE Version 94.0a1 Build ID 20210929094607.

I don't use other browsers regularly. Only other thing with tabs I can think of is gedit, and that actually improved a month or so ago.

Haven't had any system updates or anything that would have changed it on my end either. Trying to hold off so I know it's firefox and not something else.

I can drag in system, I cannot drag text in webpages, in address bar, in search bar, bookmarks sidebar. In customize mode icons/buttons disappear after being dragged.

Sounds like a different bug or problem.

See Also: → 1733283

Haven't had happen in a while. Closing

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1735348

Happened to me today with the exact same symptoms as described in previous comments (couldn't drag tabs and a variety of other things)

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

(In reply to Latrolage from comment #13)

Happened to me today with the exact same symptoms as described in previous comments (couldn't drag tabs and a variety of other things)

Please open about:support, click on "Copy text to clipboard" and paste it here.

Attached file about:support data

(In reply to Latrolage from comment #15)

Build ID: 20211006213819

Please update your Nightly, it's 3 weeks old. Main menu > Help > About Nightly.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1735348

Started happening again

(In reply to zlice from comment #18)

Started happening again

Can you please use mozregression to find broken commit?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Use_Mozregression_tool

Also which version is broken for you?
Thanks!

Flags: needinfo?(zlice555)

I can confirm. 20211118034937 on Manjaro KDE, minutes after update. I cannot bisect, because I don't know why this happens (no STR) and does not happen in clean build on demand.

Flags: needinfo?(zlice555)
You need to log in before you can comment on or make changes to this bug.