Closed Bug 1733475 Opened 4 months ago Closed 4 months ago

stickers panel is not fully displayed on app.element.io

Categories

(Core :: CSS Parsing and Computation, defect)

defect

Tracking

()

RESOLVED FIXED
94 Branch
Webcompat Priority ?
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- fixed
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: ksenia, Assigned: emilio)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached file 84751.html (obsolete) —

This was originally reported in https://github.com/webcompat/web-bugs/issues/84751

To reproduce:

  1. Open the attached test case 84751.html in Firefox release/ Nightly and observe the block on the right

Expected:
The panel inside the iframe is fully visible

Actual:
The width of the panel is around 5px, so only a small part of it is visible

The issue only happens when I change the display property of a wrapper element dynamically with a setTimeout and works ok if the element is displayed by default. This is just to illustrate the behaviour - on the original site, it is changed on click.

From mozregression:

 2:43.09 INFO: Narrowed integration regression window from [98a3f624, a74fee26] (3 builds) to [98a3f624, 58909c79] (2 builds) (~1 steps left)
 2:43.09 INFO: No more integration revisions, bisection finished.
 2:43.09 INFO: Last good revision: 98a3f624dd0822d471b46703d4cb0c8bafc1674b
 2:43.09 INFO: First bad revision: 58909c79343bc9145173cfcd54c277cd343eb2a8
 2:43.09 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=98a3f624dd0822d471b46703d4cb0c8bafc1674b&tochange=58909c79343bc9145173cfcd54c277cd343eb2a8
Attached file 84751-iframe.html
Attached file 84751.html
Attachment #9243804 - Attachment is obsolete: true
Keywords: regression
Regressed by: 1718337
Has Regression Range: --- → yes

Hi Emilio, could you please take a look?

Flags: needinfo?(emilio)
Webcompat Priority: --- → ?

Thanks for the excellent reduced test-case Ksenia! Of course, will take a look.

Assignee: nobody → emilio
Flags: needinfo?(emilio)

Thanks!

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27a8244cc1ff
Ensure to copy over the viewport/font units invalidation bits when reusing reset properties. r=jfkthame
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/31070 for changes under testing/web-platform/tests
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Upstream PR merged by moz-wptsync-bot

Did you want to nominate this for ESR uplift?

Flags: needinfo?(emilio)

Comment on attachment 9243928 [details]
Bug 1733475 - Ensure to copy over the viewport/font units invalidation bits when reusing reset properties. r=jfkthame,#style

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Simple invalidation correctness fix.
  • User impact if declined: comment 0
  • Fix Landed on Version: 94
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Copy some bits so that we invalidate correctly in some edge cases. Very simple fix.
  • String or UUID changes made by this patch: none
Flags: needinfo?(emilio)
Attachment #9243928 - Flags: approval-mozilla-esr91?
Duplicate of this bug: 1735447

Comment on attachment 9243928 [details]
Bug 1733475 - Ensure to copy over the viewport/font units invalidation bits when reusing reset properties. r=jfkthame,#style

Approved for 91.3esr.

Attachment #9243928 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
Duplicate of this bug: 1737270
You need to log in before you can comment on or make changes to this bug.