Closed Bug 1733576 Opened 4 months ago Closed 4 months ago

Ctrl-Q/Cmd-q quit warning shows a PluralForm warning (PluralForm.jsm: Index #0 of ';Close #1 tabs?' for value 1 is invalid -- plural rule #1; called by BG__onQuitRequest) in the browser console when invoked with a single window+tab

Categories

(Firefox :: General, defect)

Desktop
macOS
defect
Points:
1

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- verified
firefox95 --- verified

People

(Reporter: Gijs, Assigned: enndeakin)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fidefe-mr11-close-tabs])

Attachments

(1 file)

STR:

  1. open Firefox on macOS/Linux
  2. ensure that only 1 tab in 1 window is open
  3. hit the quit shortcut (cmd/ctrl-q)

ER:
no warnings in the console when the dialog shows up

AR:

PluralForm.jsm: Index #0 of ';Close #1 tabs?' for value 1 is invalid -- plural rule #1; called by BG__onQuitRequest

This is because we're trying to access the "singular" value for the PluralForm, which is unexpected.

Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/24c9d3d650b1
remove extraneous attempt to get the close tabs dialog title, r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Set release status flags based on info from the regressing bug 1726736

Hello! I have managed to reproduce the issue with firefox 94.0a1 (2021-10-01) on Ubuntu 20.04. I can confirm that the issue is fixed with firefox 94.0b8 and 95.0a1 (2021-10-21) on MacOS and Ubuntu 20.

I will update the flags and set the correct resolution.

Thank you!

Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.