Closed Bug 1733754 Opened 4 months ago Closed 4 months ago

Dropdown list don't show properly on add-ons when enabling native wayland

Categories

(Core :: Widget: Gtk, defect, P2)

Firefox 92
defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: preacca, Assigned: stransky)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image Screenshot_KDE.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

Mozilla/5.0 (X11; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0

  1. Run MOZ_ENABLE_WAYLAND=1 ./firefox -ProfileManager -no-remote
  2. Install YouTube High Definition, Tab Session Manager, Simple Translate, or [User-Agent Switcher and Manager] (https://addons.mozilla.org/en-US/firefox/addon/user-agent-string-switcher/)
  3. Click these add-ons on the toolbar and check their dropdown list.

Actual results:

GNOME: The dropdown menu is not displayed.
KDE Plasma: The dropdown menu is displayed in the wrong position.

Expected results:

The dropdown menu will appear the same as when the window protocol is xwayland.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Priority: -- → P2

Yes, I can reproduce it with YouTube High Definition addon.

Assignee: nobody → stransky
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/c82e3005fd30
[Wayland] Use global popup coordinates when its not shown, r=jhorak
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
See Also: → 1734368

I see browser freeze when the popup is opened/closed repeatedly. Filed as Bug 1734368.

The patch landed in nightly and beta is affected.
:stransky, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(stransky)
Regressions: 1735294

Comes with regressions (mostly caused by Gtk backend) so better to keep in nightly.

Flags: needinfo?(stransky)
You need to log in before you can comment on or make changes to this bug.