Closed Bug 1734051 Opened 2 months ago Closed 2 months ago

Fission's Amazon AWFY warm load time regression is mostly fixed, but doesn't match e10s with Olli's paint suppression tweaks

Categories

(Core :: DOM: Content Processes, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 - wontfix
firefox95 --- wontfix

People

(Reporter: cpeterson, Unassigned)

References

(Regression)

Details

(Keywords: regression)

After Nika's changes for bug 1731792 landed on 2021-09-29, Amazon AWFY warm load time improved a lot but did not reach e10s performance:

How much do we care? Nika improved Amazon warm load perf a lot (~470 to ~290 ms), actually beating Fission and e10s before the original regressions (~380 ms). The issue is that, in the meantime, Olli's paint suppression tweaks in bug 1731132 improved e10s's Amazon warm load perf but didn't help Fission.

My take on this would be that we should look at a past baseline for e10s against current fission here and not compare two moving targets that are both influenced by our ongoing changes. I always understood our fission performance goal as a general "things should not become noticeable worse than they were before". I'd strongly suggest to fix a (past) release we want to benchmark fission against. But in the end this seems to be a product decision, so chaining in Mike.

Flags: needinfo?(mconca)

Both fixes are shipping in Fx94, so users upgrading from an older version of Firefox will see a net improvement of about 100ms. No reason to worry about this.

Flags: needinfo?(mconca)

(In reply to Mike Conca [:mconca] from comment #2)

Both fixes are shipping in Fx94, so users upgrading from an older version of Firefox will see a net improvement of about 100ms. No reason to worry about this.

SGTM. I will resolve this bug as WONTFIX. We have more important performance issues to worry about.

Status: NEW → RESOLVED
Fission Milestone: ? → ---
Closed: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.