carrefour-multimedia.com - bad sniffing

RESOLVED FIXED

Status

P1
major
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: fbonny, Assigned: fbonny)

Tracking

Details

(Whiteboard: [USERAGENT][sniffing][havefix][havecontact][DENY], URL)

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
This page asks for IE 5 or Netscape 6.

Contact :  webmaster@carrefour.com

Comment 1

16 years ago
Verified in build 2002100508 PC/Win98.

Their browser detection
http://www.carrefour-multimedia.com/Includes/js/versionning.js is looking for
'Netscape' in the UA string to pick out Netscape 6+.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Whiteboard: [USERAGENT]
yup, they need to sniff better.
a way to to this is to detect gecko instead :
http://devedge.netscape.com/viewsource/2002/browser-detection/
Summary: Mozilla is not detected (asking for download Netscape) → carrefour-multimedia.com - bad sniffing
Whiteboard: [USERAGENT] → [USERAGENT][sniffing][havefix][havecontact]

Comment 3

16 years ago
*** Bug 174509 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
Just mailed to the webmaster. Wait and see.
(Assignee)

Comment 5

16 years ago
They are open and ready to add a patch. I'm trying to make one.
Note: this bug is followed by the AFUL (french association for free software) too.

Updated

16 years ago
Blocks: 111001
Quote from bug 111001 :


"The software used on the server side is written by a french company, Suadela.
getting in touch with them (namely Fred).
...
Got in touch with Suadela. The tech contact is Frederic de Badereau
<fbadereau@suadela.fr>
Fred knows about this bugzilla bug report and will have a look."

Perhaps this person should be contacted too

Updated

16 years ago
OS: Windows 98 → All
Hardware: PC → All
Whiteboard: [USERAGENT][sniffing][havefix][havecontact] → [USERAGENT][sniffing][havefix][havecontact][DENY]
(Assignee)

Comment 7

16 years ago
Note that the webmaster answered me that they are thinking to a new version and
aware of the problem. Two ways to fix are better than one.
:-)

They have understood that the AFUL or the evangelists can help too.

Comment 8

16 years ago
Problem still not solved...
I will write to the webmaster

Comment 9

16 years ago
*sigh*
Got an answer from the "customer support" saying that they will do nothing. But
(I guess) the answer was made from someone who does not understand the
problem... It is not even written in good french:

"Nous faisons suite à votre mail de ce jour concernant le navigateur Modzilla
enpêchant la visite de notre site www.carrefourmultimedia.com. 

Nous sommes conscients du manque à gagner que cela peut impliquer, mais il n'est
toujours prévu à ce jour de permettre les utilisateurs de Modzilla de visiter
notre site."

Let's wait for a technical answer from the webmaster.

Comment 10

16 years ago
Created attachment 120678 [details] [diff] [review]
patch

this patch (although Bad: sniffs name too) against 
wget http://www.carrefour-multimedia.com/Includes/js/versionning.js
would at least work for all Mozilla/5.0 compatible browsers and take less than
2 minutes to apply.

the site works fine when accessed directly from
http://www.carrefour-multimedia.com/data/fr/accueil/index.asp
(Assignee)

Comment 11

16 years ago
Mail after mail, I'm in relation with the internet responsable of the group. A
new site is preparing and will support more browsers. But I wil send the patch
to him, of course.

Comment 12

16 years ago
assigning to Fabrice since he/she is doing the contacting.  accept the
assignment if this is okay with you.
Assignee: nitot → fbonny
(Assignee)

Comment 13

16 years ago
(he, please :-) )
That's ok and the patch is gone.

Comment 14

16 years ago
->fr
Component: Europe: West → French

Comment 15

15 years ago
wfm FF 20040213 Win2k
-> Fixed
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.