If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] Need possibility to always allow session cookies

RESOLVED DUPLICATE of bug 75915

Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED DUPLICATE of bug 75915
15 years ago
15 years ago

People

(Reporter: Ere Maijala (slow), Assigned: Stephen P. Morse)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
In Mozilla there is no way to always allow session cookies. A user might, for
example, want to be asked before storing a cookie except if it's only for the
session. IE can do this (gasp), and it would be quite a useful feature. My
suggestion would be to add a checkbox "[ ] Always allow session cookies" to
cookie preferences.

I tried to search the cookie bugs for this, but, although plenty, they seem to
be cluttered with other suggestions.
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

15 years ago
Blocks: 100573

Comment 1

15 years ago
Are there enough sites that use session cookies but not permanent cookies that
this option would significantly cut down on how often you see the allow-cookie
dialog?  If not, I prefer the approach in bug 75915, which would replace the
allow-cookie dialog with a status bar icon.  Instead of setting Mozilla to ask
you before setting a cookie, you would set it to downgrade cookies to
session-only for sites not in the whitelist.  Clicking the status bar icon would
add the current site to the whitelist, allowing the site's cookies to last
longer than the session.
(Reporter)

Comment 2

15 years ago
Yep, the approach in bug 75915 sounds better. Marking as dup.

*** This bug has been marked as a duplicate of 75915 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.