Closed Bug 1734984 Opened 2 months ago Closed 2 months ago

sender.url of the message sent at document_start is the previous page URL in this tab

Categories

(WebExtensions :: General, defect, P1)

Firefox 93
defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox93 wontfix, firefox94 wontfix, firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: woxxom, Assigned: zombie)

References

(Regression)

Details

(Keywords: regression, testcase, Whiteboard: [addons-jira])

Attachments

(2 files)

Attached file test-ff-ext.zip

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.71 Safari/537.36

Steps to reproduce:

  1. install the attached extension
  2. open a new tab, open devtools console
  3. paste-and-go to https://thumbs3.imagebam.com/23874/626770238732222.jpg
  4. Press the back button, then forward button

Repeat the last step several times and look in devtools console

Actual results:

Console occasionally prints BAD: about:newtab

Expected results:

Console prints GOOD

The Bugbug bot thinks this bug should belong to the 'WebExtensions::Untriaged' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Product: Firefox → WebExtensions
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → General
Ever confirmed: true
Flags: needinfo?(tomica)
Keywords: regression, testcase
Regressed by: 1729395

FWIW, since content scripts don't rerun with BFCache + fission (bug 1734991), it hides this particular bug in newer FF so a more universal STR would need to force-disable bfcache somehow.

Assignee: nobody → tomica
Severity: -- → S2
Flags: needinfo?(tomica)
Priority: -- → P1
Whiteboard: [addons-jira]
Status: NEW → ASSIGNED

Tomislav, ois that something that should be fixed and uplifted to beta/release or is that something that can ride the 95 train? (asking because of P1/S2 status)

Flags: needinfo?(tomica)

I'm working on this with the intention of uplifting. It's not the end of the world if we don't get it, but I would like to.

Flags: needinfo?(tomica)

While trying to write a minimal regression test for this bug, I could only reproduce it when navigating to an image. Did you see any other circumstances under which this bug is manifested?

Flags: needinfo?(woxxom)

Changing the severity according to new finding of limited scope of the bug.

Severity: S2 → S3

So far only with an image.

Severity: S3 → S2
Flags: needinfo?(woxxom)

Somehow the bugtracker gave me the rights to reassign the severity :-)

Severity: S2 → S3

Thanks for the confirmation.

(In reply to Pascal Chevrel:pascalc from comment #5)

Tomislav, ois that something that should be fixed and uplifted to beta/release or is that something that can ride the 95 train? (asking because of P1/S2 status)

Given the new info, and since this bug has already shipped in 93, I will not be asking for uplifts here, this can ride 95 to release.

Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ded3930cc57d
Use WindowGlobalParent.documentURI for sender.url r=robwu

Backed out changeset ded3930cc57d (Bug 1734984) for causing bc failures in browser_ext_contentscript_sender_url.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/528c3399317b8878d44cb7519e24d4d5a6f109d5
Push with failures, failure log.

Flags: needinfo?(tomica)
Flags: needinfo?(tomica)
Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6961dc913ccb
Use WindowGlobalParent.documentURI for sender.url r=robwu
Pushed by tjovanovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55a504b8e617
Use WindowGlobalParent.documentURI for sender.url r=robwu
Flags: needinfo?(tomica)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.