"the document contains no data" popup on every visit.

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: josefek, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910

Popup appears on every visit to ubl.com.  Also appears on other pages; for
instance, www.perlmonks.org.  On perlmonks it seems to choke on the ad push from
adfu.blockstackers.com every time.

Reproducible: Always

Steps to Reproduce:
1. Go to, say, http://perlmonks.org
2. Wait.
3. There it is!

Actual Results:  
"The document contains no data" error popup.

Expected Results:  
ummm, loaded the page without the error?
(Reporter)

Comment 1

15 years ago
Also occurs on the url http://cardmemberservices.firstusa.com/index.jsp,
bringing the error up multiple times during page load. jsfk
a) Have you cleared the disk cache 
b) Do you use a proxy ?
c) Do you use some kind of ad blocking ?
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa
(Reporter)

Comment 3

15 years ago
>>a) Have you cleared the disk cache?
Yes. No change in status.

>>b) Do you use a proxy ?
No.
>>c) Do you use some kind of ad blocking ?
No. Norton Internet security is installed, but ad blocking is not enabled.

I have also uninstalled and reinstalled mozilla to no avail.
jsfk
(Assignee)

Comment 4

15 years ago
perhaps norton internet security is the culprit.  it may be acting as a
transparent proxy, inspecting the network traffic.  can you try disabling it to
see if that corrects the problem?  thx!
(Reporter)

Comment 5

15 years ago
Nope.  I killed Norton Internet Security altogether, navigated to
http://cardmemberservices.firstusa.com/index.jsp, and had the same error boxes
appear.
jsfk
(Assignee)

Comment 6

15 years ago
do you get any sort of similar error in IE or Netscape 4.x?
(Reporter)

Comment 7

15 years ago
I don't have Netscape on my box, but IE behaves itself on the aforementioned
sites.  It really seems to be a problem that involves data being loaded in from
locations remote to the immediate url.  Just as the choke on perlmonks.org with
the adfu push, it seems that the error occurrence on
http://cardmemberservices.firstusa.com/index.jsp originates from
ad.doubleclick.net.  I've double checked all my mozilla settings (accepting
images/cookies from sites other than the originating one, etc), and tested this
out with both my firewall and antivirus disabled.
jsfk
(Assignee)

Comment 8

15 years ago
interesting.. i'm not sure what to suggest at this point.  you might want to
give moz a try with a new profile.
(Reporter)

Comment 9

15 years ago
Yeah. I'm pretty stumped too. I just did the following:
Uninstalled mozilla.
deleted the install dir.
deleted all the mozilla info in docs and settings
deleted all registry entries for mozilla
rebooted
reinstalled.
voila... same problem.  It seems like it has to be something outside of mozilla
causing the issue but, then, why is IE uneffected?  Very strange.  Still, my
machine is overdue for a rebuild.  Now, if the error returns after that, I'll be
truly buffaloed.
jsfk
(Assignee)

Comment 10

15 years ago
do you have the ability to run a packet trace?  there's a really good GUI tool
available from www.ethereal.com that works on windows (hopefully winxp as well)
that can tell us what is going on at the TCP/IP level.  that may offer up some
clues.  the website provides some useful tips on getting it setup.  if you have
time to do a packet trace it'd be really great!  thx!!
(Reporter)

Comment 11

15 years ago
Actually, I've been running ethreal and watching things.  Consider this case
closed... rather than simply disabling norton internet security, I eyeballed the
running processes and discovered that telling NIS to "disable" doesn't kill
their symproxy thread.  I then opted to completely uninstall NIS, and there you
go; the problem is gone.
Now, why it was effecting Mozilla and not IE is a toughie tho...

jsfk
(Assignee)

Comment 12

15 years ago
perhaps NIS is doing User-agent sniffing??  Sounds wild, but you might try
overriding mozilla's UA string.  put this in your prefs.js file:

user_pref("general.useragent.override",
          "Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)");

perhaps perhaps :-/
Mozilla will crash if Mozilla finds a Java plugin and you have this UA string..

Comment 14

15 years ago
I cannot dupe the problem.

Darin, feel free to change the Status out of UNCONFIRMED if you believe this is
no longer an issue.
(Assignee)

Comment 15

15 years ago
some of these problems may have been due to broken subframes (iframes). 
adamlock landed changes that suppress error dialogs for subframes.  perhaps his
fix explains why this bug appears non-reproducible today, or perhaps the
problems people have been seeing are purely dependent on how they connect to the
internet because this error corresponds to the server (or somebody inbetween)
dropping the connection on the floor.

Comment 16

15 years ago
I have been getting sporadic but definitely more common messages of "Document
contains no data" on various sites.  I am using build 2002102208 on W2K.  I do
not  use a proxy but I do use Zonealarm.
(Assignee)

Comment 17

15 years ago
Jay: can you please try disabling zonealarm and tell us if it helps.  there have
been other reports of it not working well with mozilla.

Comment 18

15 years ago
I am not seeing this problem since the time I reported, and after upgrading to
the next build.
thx

-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 20

15 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.