Closed Bug 1735151 Opened 4 months ago Closed 3 months ago

3.13 - 2.95% tresize / tresize + 1 more (Linux) regression on Thu October 7 2021

Categories

(Core :: Widget: Gtk, defect)

defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- unaffected
firefox95 --- fixed

People

(Reporter: aesanu, Assigned: stransky)

References

(Regression)

Details

(4 keywords)

Attachments

(1 file)

Perfherder has detected a talos performance regression from push 1c581d243b8752eef64ab15aca97e11afae39b67. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
3% tresize linux1804-64-shippable-qr e10s stylo webrender-sw 17.80 -> 18.36
3% tresize linux1804-64-shippable-qr e10s fission stylo webrender 22.07 -> 22.75
3% tresize linux1804-64-shippable-qr e10s stylo webrender 18.54 -> 19.09

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(stransky)

Set release status flags based on info from the regressing bug 1733620

Will look at it.

Assignee: nobody → stransky
Flags: needinfo?(stransky)
Flags: needinfo?(stransky)
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/d85ed5eec458
[Linux] Don't resize window when we request move only, r=emilio
Flags: needinfo?(stransky)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1734758

(In reply to Pulsebot from comment #4)

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/d85ed5eec458
[Linux] Don't resize window when we request move only, r=emilio

== Change summary for alert #31922 (as of Mon, 18 Oct 2021 03:06:53 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
5% tresize linux1804-64-shippable-qr e10s fission stylo webrender 22.88 -> 21.81
5% tresize linux1804-64-shippable-qr e10s fission stylo webrender 22.85 -> 21.79
3% tresize linux1804-64-shippable-qr e10s stylo webrender 19.26 -> 18.62
3% tresize linux1804-64-shippable-qr e10s stylo webrender-sw 18.37 -> 17.82

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=31922

Cool, Thanks!

Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.