Closed Bug 1735243 Opened 2 months ago Closed 2 months ago

Add dummy tab routines to SeaMonkey mailnews tab browser.

Categories

(SeaMonkey :: MailNews: General, task)

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.92
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: frg, Assigned: frg)

Details

(Whiteboard: SM2.53.10)

Attachments

(1 file)

tabmail.xml extends tabbrowser.xml. Some code references unimplemented functions for tabmail.xml.

Looking at the tabbrowser code referencing it I think we can get away with implementing _getTabForContentWindow and getBrowserIndexForDocument as dummies. Didn't notice any problems for several weeks in 2.53.10b1 pre doing so.

PS. Thought there was an old bug already but didn't find it.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: console errors when opening mailnews
Testing completed (on m-c, etc.): 2.53.10b1 pre
Risk to taking this patch (and alternatives if risky): dummy implenetation broken before.
String changes made by this patch: --

Attachment #9245349 - Flags: review?(iann_bugzilla)
Attachment #9245349 - Flags: approval-comm-release?
Attachment #9245349 - Flags: approval-comm-esr60?

Comment on attachment 9245349 [details] [diff] [review]
1735243-undefinedbrowseri-25310.patch

[Triage Comment]
Seems to be okay r/a=me

Attachment #9245349 - Flags: review?(iann_bugzilla)
Attachment #9245349 - Flags: review+
Attachment #9245349 - Flags: approval-comm-release?
Attachment #9245349 - Flags: approval-comm-release+
Attachment #9245349 - Flags: approval-comm-esr60?
Attachment #9245349 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/dd9893914573
Fix undefined browser[i] console error in mailnews. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.92
You need to log in before you can comment on or make changes to this bug.