Last Comment Bug 173561 - request flags should use a #define instead of masking w/ 0xffff
: request flags should use a #define instead of masking w/ 0xffff
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 All
: -- minor (vote)
: ---
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 13:44 PDT by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2011-06-09 12:11 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple fix (2.48 KB, patch)
2011-06-06 21:38 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
cbiesinger: review+
rjesup: checkin+
Details | Diff | Review

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2002-10-09 13:44:49 PDT
In several places (imgLoader.cpp, nsLoadGroup.cpp, etc) there is code that masks
requestflags with 0xFFFF to separate the low 16 bits from the top 16 used by
subclasses.  This should be a #define, as per our discussion in IRC.
Comment 1 Darin Fisher 2006-06-20 13:19:55 PDT
-> default owner
Comment 2 [:jesup] on pto until 2016/7/5 Randell Jesup 2011-06-06 21:38:18 PDT
Created attachment 537732 [details] [diff] [review]
Simple fix

Turns out the hard constant 0xFFFF was still sitting in imgLoader.cpp and nsLoadGroup.cpp 9 years later...

Simple fix.  It doesn't appear to be elsewhere, other than those two files.

Guessing from r= in imgLoader.cpp that Joe Drew is appropriate for review.
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2011-06-09 12:10:42 PDT
Checked in: http://hg.mozilla.org/mozilla-central/rev/26a8cb097609

Note You need to log in before you can comment on or make changes to this bug.