Closed Bug 1736166 Opened 2 months ago Closed 1 month ago

Border-image borders are not rendering consistently in Firefox 93

Categories

(Core :: Web Painting, defect)

Firefox 93
defect

Tracking

()

RESOLVED DUPLICATE of bug 1729937

People

(Reporter: jeff.bridgforth, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

I am using border-image to create gradient borders on a client site. In Firefox 93, some of the borders are missing on elements. If I inspect the element, the border will then render. It is consistently happening that the bottom border is missing on an element when it is not in the viewport on refresh.

I downloaded Firefox 92 and the borders rendered as expected after multiple refreshes. Same was true of Firefox nightly. I even deleted my Firefox profiles and started fresh with Firefox 93 and same result.

MacOS 10.14.6

Actual results:

After refreshing, deleting and creating a new profile, borders are still missing on elements and it is not consistent as to which border is missing. See attached screenshot. Staging server of client site: https://cross-border-oecd-opsi.flywheelsites.com/

Expected results:

All the borders rendered by the browser.

I found another site that the bottom border using gradients and border-image are not rendering correctly.

I can reproduce the iussue in Firefox93.0 Windows10, but not in Firefox94.0beta and Nightly95.0. It was fixed by Bug 1729937.

Fixed range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9454a21f0863be403ec585d4b0bc176656f170ed&tochange=f52e47992f26b86ea97ae16ff4908438f245dbc8

Hi jeff, thank you for opening the bug
it seems its already fixed in beta 94.0b7 and nightly 95.

Please try on the latest nightly version and let us know if you see any other issue on the second site you found:
Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/

thanks.

Flags: needinfo?(jeff.bridgforth)

Pablo,

When will version 94 come out?

Flags: needinfo?(jeff.bridgforth)

The Bugbug bot thinks this bug should belong to the 'Core::ImageLib' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → ImageLib
Product: Firefox → Core
Component: ImageLib → Web Painting

94 comes out on nov 2.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1729937
You need to log in before you can comment on or make changes to this bug.