Closed Bug 1736443 Opened 8 months ago Closed 7 months ago

Add connect button to cZ Networks Editor

Categories

(SeaMonkey :: Chat, enhancement)

enhancement

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.93
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.11)

Attachments

(2 files)

At the moment there is no straight forward way to connect to a network unless the Available networks are listed in the client tab.
One potential fix is to add a connect button to the cZ Networks Editor dialog.

Screenshot of potential connect button.

Attachment #9246515 - Flags: feedback?(frgrahl)

The other option is to put the "Connect to Network" button somewhere in the Add/Edit/Remove Network list.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: no easy way to connect to a network via GUI
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: 2 new strings

Attachment #9247410 - Flags: review?(frgrahl)
Attachment #9247410 - Flags: approval-comm-release?
Attachment #9247410 - Flags: approval-comm-esr60?

Comment on attachment 9247410 [details] [diff] [review]
1736443-irc-connect-network-25311.patch

LGTM

Attachment #9247410 - Flags: review?(frgrahl)
Attachment #9247410 - Flags: review+
Attachment #9247410 - Flags: approval-comm-release?
Attachment #9247410 - Flags: approval-comm-release+
Attachment #9247410 - Flags: approval-comm-esr60?
Attachment #9247410 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4efda1797484
Add connect button to cZ Networks Editor. r=frg

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.11
Target Milestone: --- → seamonkey 2.93
Blocks: 1744440

Comment on attachment 9246515 [details]
NetworksEditorConnect.png

Forgot the feedback :)

Attachment #9246515 - Flags: feedback?(frgrahl) → feedback+
You need to log in before you can comment on or make changes to this bug.