Closed Bug 1736518 Opened 2 months ago Closed 14 days ago

[Linux] Polish titlebar config

Categories

(Core :: Widget: Gtk, task)

task

Tracking

()

RESOLVED FIXED
95 Branch

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 2 obsolete files)

Right now we don't test titlebar rendering in mozilla testsuite. That leads to various issues and regressions.

See Also: → 1509931

Recently -moz-gtk-csd-hide-titlebar-by-default is used to control initial state of titlebar rendering on Linux.
This is used on Linux only, such preference confuses Mozilla test suite which expects browser.tabs.drawInTitlebar only
as it's used on other platforms.

Let's align Linux behaviors with Win/Mac and set browser.tabs.drawInTitlebar directly at browser start (if it's not already set).

Depends on D128995

To more properly support Linux having a different default at runtime.

Expose the resolved value in appinfo for convenience, and use it in the
front-end as needed.

This is a regression from bug 1681356. nsWindow::GtkWindowDecoration()
default-initializes a GtkWindowDecoration, which ends up being
GTK_DECORATION_SYSTEM since that's the first variant.

Fix the check by using the proper function
GetSystemGtkWindowDecoration(). Quite a footgun...

Depends on D129004

Clean up the check while at it.

Depends on D129005

Attachment #9246809 - Attachment is obsolete: true
Attachment #9246808 - Attachment is obsolete: true
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62d204b08dce
Make browser.tabs.drawInTitlebar a tri-state. r=stransky,Gijs
https://hg.mozilla.org/integration/autoland/rev/ad3d2766d9da
Fix CSD check in nsLookAndFeel. r=stransky
https://hg.mozilla.org/integration/autoland/rev/537090f8fa57
Remove GTK_CSD_DECORATION_UNKNOWN. r=stransky
Keywords: leave-open
Regressions: 1739539

Should this bug still be open? Maybe it would better to create a new followup bug if there is going to be more later.

Flags: needinfo?(emilio)

Yeah maybe we should retitle this bug and close it? WDYT Martin?

Flags: needinfo?(emilio) → needinfo?(stransky)

Hm, the try does not look good. Okay, let's close it and file another one for CSD enabled in testsuite.

Flags: needinfo?(stransky)
Summary: [Linux] Enable titlebar rendering in mozilla test suite → [Linux] Polish titlebar config
Status: NEW → RESOLVED
Closed: 14 days ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.