Closed Bug 1736523 Opened 7 months ago Closed 7 months ago

[Linux] Drag and drop stopped working

Categories

(Core :: Widget: Gtk, defect, P1)

Firefox 95
Unspecified
Linux
defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- unaffected
firefox95 + verified

People

(Reporter: ke5trel, Assigned: stransky)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Drag and drop no longer works on Ubuntu 21.04. Tabs cannot be dragged around the tab strip, dropping on the tab strip opens a new window on Wayland. Dropping text into the address bar or between tabs doesn't do anything etc. Occurs on both Wayland and XWayland.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1117eee12de7907d215343eafb1156d50e4b7ab5&tochange=f4a1cfc1bb0f7d72baa621c2a145358b74de8945

Regressed by Bug 1736377.

Interesting, seems to be related to the inner window changes. Will look at it.

Assignee: nobody → stransky
Priority: -- → P3
Duplicate of this bug: 1736589

[Tracking Requested - why for this release]: Drag & drop is an important feature.

Possibly related to the inability to customize the toolbar in today's Nightly. Bug 1736683.

Priority: P3 → P1
Duplicate of this bug: 1736683
Duplicate of this bug: 1736736
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/d2777033b7d3
[Linux] Get inner window for D&D operations r=jhorak
Summary: [Linux] Drag and drop stopped working → [Linux] Tab-bar drag and drop stopped working

In regards to the title change, is this issue confined to the tab bar? I'm seeing several other drag and drop issues (to rearrange bookmarks on the Bookmarks Toolbar, or in Manage Bookmarks, toolbar elements in Customize Toolbar, emails in Thunderbird). I haven't confirmed they all have the same regression range, but suspect they do. Let me know if you want confirmation or if I should open separate bugs.

There is already bug 1736683 for Customize Toolbar, but it was duped to this bug.

Sorry, the title change was my own misunderstanding (and failed attempt at clarification). I made that tweak after encountering this with the tab-bar, and I hadn't realized that other forms of drag-and-drop were also broken. I'll restore the original title, since I assume this bug & the fix covers the broader issue. (And to the extent that any other drag&drop behavior is still broken after this fix hits Nightlies, we can of course track followup work in new/un-duped bugs.)

Summary: [Linux] Tab-bar drag and drop stopped working → [Linux] Drag and drop stopped working

No worries. Thanks :dholbert! Just to put my own doubts to rest, I can confirm that creating or rearranging bookmarks by drag and drop to the Bookmarks Toolbar bisects to the same range, so is likely the same issue. Will keep an eye on it.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Flags: qe-verify+

Reproduced the issue with Firefox 95.0a1 (2021-10-19) on Ubuntu 21.0.4.
The drag and drop work as expected on Ubuntu 21.04 with Firefox 95.0b3.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.