Closed Bug 1736745 Opened 2 months ago Closed 5 days ago

Smarter Contextual Search test rollout turned on options even when not activated

Categories

(Firefox :: Address Bar, defect)

Firefox 93
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: arigato, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

Installed Firefox 93

Actual results:

Two options, Provide search suggestions (Search tab) and "Contextual suggestions" (Privacy tab), were both enabled without my consent or any notification. Neither were previously enabled, ever.

I assume this happened as part of the test rollout of the new "smarter contextual suggestions" feature. Since I assume both options would logically be required to use that new feature, and I can see no other reason you might suddenly be turning them on. The could to enable them clearly being outside the opt-in process for the new feature, at least in some use cases.

Please note: Not only did I not get prompted to opt-in to this new feature rollout, even if I had been given the option I NEVER would have agreed to enable it. I don't need or want the contextual search, as it annoys the hell out of me. That is why those two options, as well as all the other options under "Address Bar — Firefox Suggest", have been disabled as long as I have used Firefox. Or at least as long as those options were first available.

I would also point out that it is particularly concerning that a privacy related option was turned on without my consent. Changing privacy options should NOT happen without user consent. Ever.

Expected results:

Leave my settings the heck alone.

If I had chosen to opt-in to the new feature, I could perhaps understand as I can see both these options being required for the new feature. I did not though.

Also note that I have confirmed that I do not have the new feature installed as the text "Firefox will have access to your location, search queries, and visited sites" does not and did not appear below the "Contextual suggestions" option. Per this article: https://support.mozilla.org/en-US/kb/navigate-web-faster-firefox-suggest?as=u&utm_source=inproduct.

The Bugbug bot thinks this bug should belong to the 'Firefox::Address Bar' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Address Bar

The severity field is not set for this bug.
:adw, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(adw)

Did you face any of these changes on Firefox 94?
Thanks.

Flags: needinfo?(arigato)

Yes, these two new types of suggestions are enabled by default for people in the U.S. Since this bug was filed, the preferences UI has been redesigned to break out data collection into its own toggle, and there are now three separate toggles: two for the two types of suggestions and one for data collection. At no time has data collection been enabled by default, only the new suggestions, even in the old preferences design when there were only two checkboxes. This is not a bug and we're going to continue to enable suggestions by default for U.S. users while requiring user opt-in for data collection, so I'll close this.

Status: UNCONFIRMED → RESOLVED
Closed: 5 days ago
Flags: needinfo?(arigato)
Flags: needinfo?(adw)
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.