History sidebar and Go menu aren't updated while browsing

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: David Hyatt, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
This is reproducible with both the Go menu and the History sidebar panel (in 
the "Last Visited" view).

Get into that view and then start visiting sites.  The Go menu never updates 
to show the new sites, and neither does the history sidebar.  

Eep.
(Reporter)

Comment 1

15 years ago
Putting in 0.3 for your consideration.
Target Milestone: --- → Phoenix0.3
(Assignee)

Comment 2

15 years ago
worksforme.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
Updating the history doesn't work every time for me. Currently i'm using build
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040828
Firefox/0.9.1+ => Reopen

Try following steps to reproduce:

1. Open the history sidebar
2. Set sort order to 'last visited'
3. Set Google for your home page.
4. Click the home button to open google.com -> history sidebar / go menu are not
updated
5. Navigate several times throught images, groups etc. => if you call a page
twice the history sidebar / go menu fail to update.
6. Use back/forward to navigate back => this is working but doesn't update the
entries within the history sidebar and go menu.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Summary: History doesn't update while browsing. → History sidebar and Go menu aren't updated while browsing
Target Milestone: Phoenix0.3 → ---

Comment 5

13 years ago
The URL bar history has the same problem, with regularly selected or typed URLs
staying at the bottom of the list, and any sites visited even once since *first*
visiting the regular sites appearing higher up the list.

There is at least a workaround of deleting the unwanted entries with Shift-Delete.

(I can verify that this bug also occurs with 1.0PR on Linux.)
After closing the History sidebar and opening again, I can see that it has been
updated (at least here).

Firefox treats history in the Go-menu different from history in the sidebar "By
Last Visited".
If I visit a site that I visited earlier during the same browser-session,
Firefox does not move that site to the top of the Go-list, like in the History
sidebar. The history sidebar pulls the address away from the list and puts it on
top. The Go-list leaves the address where it is (often somewhere invisible below
the 10 items).

Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050415
Firefox/1.0+ 
 


Seems to be fixed for a while. After removing the Go menu it cannot be affected anymore. The history sidebar is updated correctly while browsing through different pages.

Tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060823 BonEcho/2.0b2

=> WFM
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: asa → bookmarks
You need to log in before you can comment on or make changes to this bug.