If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show a notice in status bar if link will open a new window

RESOLVED DUPLICATE of bug 14027

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 14027
15 years ago
13 years ago

People

(Reporter: Meik Langwald, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I'd like to have a small notice in the status bar if a link wants to open a new
window. (typically by Anchor tags with a target like "_new")
Browsing usually with tabs in one window, new windows opening when clicking on a
link are anoying. 

A small text in the status bar like "(new window)" would help here. I've seen
this in another browser, but don't recall which (Opera? Konqueror?)

(Another idea: forcing a link to be opened in the same window?)

Adding an option in Preferences/Tabbed Browsing to open all new windows as new
tabs, would not be usefull from my point of view, but break all the software
using smaller windows, for example as a login window. Older Opera releases had
this problem.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 14027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
from comment #0:
> (Another idea: forcing a link to be opened in the same window?)

This is already implemented. See Edit/Preferences/Advanced/Scripts&Plugins and
uncheck 'Open a link in new window'. It has nothing to do with JavaScript even
it's location might hint otherwise.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.