Closed Bug 1736984 Opened 2 years ago Closed 2 years ago

Address bar - Unify Lock (Site Info) with Permissions, and Key (Passwords)

Categories

(Firefox :: Site Identity, enhancement)

Firefox 93
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: patricek, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

  1. Firefox has in address bar lock (Site info)
  2. Firefox has in address bar Permissions
  3. Firefox has in address bar Key (Passwords)
  4. Why not unify them?

Actual results:

Firefox is a modern browser, of course.
But almost all Chromium browsers has one or two icons on address bar
Firefox have three different icons (Lock, permissions, and key. Except trackers protection, of course. Trackers protection should have independent icon)

Expected results:

Unify lock (site info) with permissions, and key (passwords)

The Bugbug bot thinks this bug should belong to the 'Firefox::Address Bar' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Address Bar

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0

Hi,

Thank you for opening this enhancement. I will set this as New and waiting for the developers opinion about it.

Thanks for your report.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Address Bar → Site Identity

Thanks for your suggestion!

The key icon can't really be merged into the site identity panel, because it is merely an anchor icon for the PopupNotification which shows the password save dialog. We need to show it so users can opt into saving their password.

Firefox used to have a unified panel for both connection info and permissions which we split up in Bug 1596897. I'm therefore closing this bug as WONTFIX.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
See Also: → 1596897
You need to log in before you can comment on or make changes to this bug.