Closed Bug 1737098 Opened 3 years ago Closed 3 years ago

DrawTargetSkia.cpp: the 'empty' method should be used to check for emptiness instead of 'size'

Categories

(Developer Infrastructure :: Source Code Analysis, task)

Tracking

(firefox96 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
firefox96 --- fixed

People

(Reporter: Sylvestre, Assigned: tawahpeggy98, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug, Whiteboard: [lang=C++])

Attachments

(1 file, 1 obsolete file)

Filling as a good first bug to learn workflows.

MOZ_ASSERT(mPushedLayers.size());
should use .empty() instead

https://searchfox.org/mozilla-central/rev/489e82dcc1e5afbe691ff3b1c982382914637e38/gfx/2d/DrawTargetSkia.cpp#1826

As the change is trivial, it is just to learn how to contribute to Firefox.

Found by http://clang.llvm.org/extra/clang-tidy/checks/readability-container-size-empty.html

Tutorial to contribute:
https://firefox-source-docs.mozilla.org/tools/docs/contribute/how_to_contribute_firefox.html

Please don't ask for the bug to be assigned. It will be automatically assigned to the first patch.

DrawTargetSkia.cpp:the 'empty' method should be used to check for emptiness instead of size

Depends on D129718

Assignee: nobody → tawahpeggy98
Status: NEW → ASSIGNED

Hello Sylvestre,
please I would appreciate if you can help me review this.
thanks,
Peggy

Attachment #9249152 - Attachment description: Bug 1737098 - replace size() with empty().r?Sylvestre Ledru → Bug 1737098 - replace size() with empty() r?sylvestre
Pushed by sledru@mozilla.com: https://hg.mozilla.org/integration/autoland/rev/9af56301448a replace size() with empty() r=sylvestre
Attachment #9248148 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
Product: Firefox Build System → Developer Infrastructure
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: