"File | Quit" and also "Quit" in some other menus (Bookmark editor) kills all windows

RESOLVED DUPLICATE of bug 39057

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 39057
16 years ago
13 years ago

People

(Reporter: Frank Klemm, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529 and other (other versions + other OS + other CPUs)

When I call "File | Quit", all Mozilla windows are closed, not only
the current. Closing all windows is needed so rarely, that it would be
enough to use the task manager to do this.

Window should be much more independent, so a Web browsing Window can't effect
a windows used for program documentation displaying or for the help system.

Otherwise I must start multiple tasks which significnatly slows down system and
increases memory usage.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Generate multiple windows, displaying different things like WWW, Docu, Help
3. Close a window using Quit like with Netscape 4.7
4. or Edit Bookmark browser and quit this
5. or quit some other submenus

Actual Results:  
All displayed pages are done to nirvana.

Expected Results:  
An proposal:

Pop up window:

                    Do you want to close

  [ Cancel closing Window ]  [ All windows ]  [_This_Window_] 


Mozilla works completely different to Netscape I used for 7 years.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.