Closed Bug 1737575 Opened 1 year ago Closed 1 year ago

CSD buttons are hardly visible when using "Lush — Soft" colorways theme

Categories

(Firefox :: Theme, defect)

Firefox 94
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1718846

People

(Reporter: qydwhotmail, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: ux-efficiency)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0

Steps to reproduce:

Change theme to "Lush — Soft"

Actual results:

CSD buttons don't have backgrounds, so they are hardly visible.

Expected results:

Give the button a dark contrast background.

Component: Untriaged → Theme
Keywords: ux-efficiency
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: gtk-kde
Blocks: 1725467, 1731038

Can you attach a screenshot?

Flags: needinfo?(qydwhotmail)
Attached image csd-visibility.png

Firefox 94.0b9
Operating System: openSUSE Tumbleweed 20211021
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.88.0
Graphics Platform: X11

Also about:support info would be great, since this probably depends on the GTK theme.

ah, ok, so this is probably breeze or such.

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

Also about:support info would be great, since this probably depends on the GTK theme.

OS Theme Breeze / Adwaita-dark

Is that right? There are too much information.

Seems the information reuqired is provided.

Flags: needinfo?(qydwhotmail)

Should I report the bug in bugs.kde.org? I am not sure if it's related to breeze-gtk.

Flags: needinfo?(emilio)
Flags: needinfo?(emilio)
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE

This is basically bug 1718846: When we have a light theme with dark toolbar the CSD buttons might have lower contrast. I submitted a patch there setting the toolbar backgrounds, but probably drawing our own controls is just better.

(In reply to Emilio Cobos Álvarez (:emilio) from comment #11)

This is basically bug 1718846: When we have a light theme with dark toolbar the CSD buttons might have lower contrast. I submitted a patch there setting the toolbar backgrounds, but probably drawing our own controls is just better.

Thank you for reminding. Mark https://bugs.kde.org/show_bug.cgi?id=444367 as RESOLVED DOWNSTREAM.

You need to log in before you can comment on or make changes to this bug.