Closed Bug 1737605 Opened 3 years ago Closed 3 years ago

Incorrect error message when AutoLaunchProtocolFromOrigins is not an origin

Categories

(Firefox :: Enterprise Policies, defect, P3)

defect

Tracking

()

VERIFIED FIXED
96 Branch
Tracking Status
firefox-esr91 --- verified
firefox96 --- verified

People

(Reporter: mkaply, Assigned: mkaply)

References

Details

Attachments

(1 file)

If you specify a host instead of an origin for AutoLaunchProtocolFromOrigins you get the error:

Added by default for protocol handler - undefined.

We should show the correct error.

Also we should see if we can show the policy that's being processed in the error.

Assignee: nobody → mozilla
Status: NEW → ASSIGNED

Definitely want QA when this goes in since we can't automated test.

Basically it's going to be making sure the policies that use JSON still work via GPO:

AutoLaunchProtocolsFromOrigins
ExtensionSettings
Handlers
ManagedBookmarks
Preferences

Flags: qe-verify+
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/f7ec28ed7098
Parse JSON directly from GPO so it's properly validated. r=mtigley
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Comment on attachment 9248281 [details]
Bug 1737605 - Parse JSON directly from GPO so it's properly validated. r?mstriemer,mtigley

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Parity with 96, policy specific
  • User impact if declined: Unable to verify errors with certain policies
  • Fix Landed on Version: 96
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Has been on trunk with no issues. Unable to have automated test due to registry stuff.
Attachment #9248281 - Flags: approval-mozilla-esr91?
QA Whiteboard: [qa-triaged]

Comment on attachment 9248281 [details]
Bug 1737605 - Parse JSON directly from GPO so it's properly validated. r?mstriemer,mtigley

Approved for 91.5esr.

Attachment #9248281 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+

Verified that the following policies which use JSON are working if enabled/configured via GPO:

AutoLaunchProtocolsFromOrigins
ExtensionSettings
Handlers
ManagedBookmarks
Preferences

Verification was performed using Firefox 96.0b8 (BuildId:20211221185759) and Firefox 91.5.0esr (provided in comment 7) on Windows 10 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1750233
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: