Closed Bug 173912 Opened 17 years ago Closed 14 years ago

Address book tab-delimited export garbles characters outside locale character set

Categories

(MailNews Core :: Address Book, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 117236

People

(Reporter: eyalroz, Unassigned)

Details

(Keywords: intl)

build id: 2002-10-03-17 (although it shouldn't matter).

When exporting an address book to a tab-separated text file, characters which
aren't part of the extended Windows ASCII get written as so many question mark
(?'s). This does not happen for LDIF format export which uses some numeric
encoding for these entries. I don't what happens for CSV... since for some
reason I get the same output for CSV as for LDIF (another bug?).

I would think the output text file should be a UTF-8 file, or even a UTF-16 file.
Summary: Garbled address book export for most Unicode characters → Garbled address book tab-delimited export for most Unicode characters
Product: Browser → Seamonkey
Keywords: intl
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Confirming. The bug exists in Thunderbird also.
Assignee: racham → nobody
Status: UNCONFIRMED → NEW
Component: Address Book → MailNews: Address Book
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: nbaca → addressbook
Summary: Garbled address book tab-delimited export for most Unicode characters → Address book tab-delimited export garbles characters outside locale character set
per Mark

*** This bug has been marked as a duplicate of 117236 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.