Closed Bug 1739600 Opened 3 years ago Closed 2 years ago

The PIP is not being positioned in the bottom-right corned of the screen with wayland, but somewhere in the top-left-center

Categories

(Core :: Widget: Gtk, defect)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1621261
Tracking Status
firefox96 --- affected

People

(Reporter: danibodea, Unassigned)

References

(Blocks 2 open bugs)

Details

Note

  • When the user opens the browser with wayland window manager, loads a yourtube video and clicks the "Watch in Picture-in-Picture" button, he will notice that the PIP is not displayed in the bottom-right corner of the screen, as intended.

Affected versions

  • Nightly v96.0a1

Affected platforms

  • Ubuntu 21 + wayland

Steps to reproduce

  1. Launch browser with wayland window manager:
    a. Go into the nightly folder.
    b. Right-click and "Open in Terminal".
    c. MOZ_ENABLE_WAYLAND=1
    d. ./firefox
  2. Load https://www.youtube.com/watch?v=SXr8Rb97nIk
  3. Click the "Watch in Picture-in-Picture" button.

Expected result

  • The PIP video is displayed in the bottom-right corner of the screen.

Actual result

  • The PIP video is NOT displayed in the bottom-right corner of the screen.

Regression range

  • unknown.

Additional notes

  • This issue occurs with "wayland" Window Protocol and not with "xwayland".

Yes, we can't control PIP window placement unless a new PIP protocol is implemented.

This is also tracked in bug 1621261

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.